Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a Wacom CTF-221 graphics tablet, and I use it with Linux Wacom drivers.

However when I draw it's annoying that the mouse pointer moves with the pen and clicks outside of the drawing window.

When I draw in GIMP, I see another pointer that is "locked" inside the image, so I think that my PC sees two devices, one as a tablet and one as a virtual mouse.

Is it possible to disable this behavior, so that my tablet movement will be seen only by the program I'm drawing to?

share|improve this question
add comment

1 Answer

Personally, I found it easier to leave it the way you currently have it, especially with switching GIMP to single-window mode. But I only randomly play with my Wacom tablet, not use it seriously. That said:

Don't affect the pointer

You just need to use xinput to float the inputs that you don't want to move the core pointer (mouse pointer).

Here is what xinput looks like with my Bamboo tablet:

anthony@Watt:~$ xinput list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB-PS/2 Optical Mouse           id=9    [slave  pointer  (2)]
⎜   ↳ Wacom Bamboo 16FG 6x8 Pen stylus          id=11   [slave  pointer  (2)]
⎜   ↳ Wacom Bamboo 16FG 6x8 Finger touch        id=12   [slave  pointer  (2)]
⎜   ↳ Wacom Bamboo 16FG 6x8 Pen eraser          id=14   [slave  pointer  (2)]
⎜   ↳ Wacom Bamboo 16FG 6x8 Finger pad          id=15   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ USB-TMU-V3                                id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]

As you can see, the Wacom tablet shows up as a bunch of different pointer devices. The 'pen stylus' and 'pen eraser' are the two from the pen; 'finger touch' is using it as a touchpad; 'finger pad' is the mouse-like buttons on the tablet itself (not the pen).

To float one, just use xinput float «id». E.g., xinput float 11; xinput float 14 would make the pen (both stylus and eraser) no longer move the mouse pointer.

Next, you'll have to go to GIMP's Preferences, Input Devices, Configure Extended Input Devices and configure GIMP to handle the stylus and eraser. Similarly, you'll have to configure Inkscape, etc.

Multiple Pointers

An alternative thing you can do with xinput is to create a second (third, etc.) "master", and attach the input devices there. Then you'll have multiple mouse pointers. Not all apps know what to do with this.

anthony@Watt:~$ xinput float 12
anthony@Watt:~$ xinput create-master 2nd
anthony@Watt:~$ xinput list
⋮
⎡ 2nd pointer                                   id=16   [master pointer  (17)]
⎜   ↳ 2nd XTEST pointer                         id=18   [slave  pointer  (16)]
⎣ 2nd keyboard                                  id=17   [master keyboard (16)]
    ↳ 2nd XTEST keyboard                        id=19   [slave  keyboard (17)]
⋮
xinput reattach 12 16
share|improve this answer
    
My Wacom shows as 3 pointers (pointer, stylus and eraser), and if I disable either pointer or stylus it disables BOTH the mouse movement and the drawings. Disabling eraser has no effect. –  Lord Spectre Apr 3 '13 at 15:31
    
@LordSpectre did you go through the GIMP configuration step? You have to do that before you can draw with it, once you've disabled it moving the mouse. (Mine were already configured, that's why I didn't have to, sorry for the confusing comment edits) –  derobert Apr 3 '13 at 15:43
    
Yes I did, and it works perfectly (I see the drawing cursor and I can use pressure sensibility) when both components are enabled, however it stops working if I disable one of them. –  Lord Spectre Apr 4 '13 at 19:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.