Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am running DELL Vostro 3750, operating system Linux Mint and despite all my attempts the fan is still running very fast and loud. So far I have tried first edit Grub according to this article. Than I tried to install nvidia drivers according to this manual but all got was a screen telling me that the X screen can't be started because no X devices were found. So I had to delete /etc/X11/xorg.conf file. Before I had ubuntu 12.04 and the problems were the same. There I also tried Jupiter and the bumlebee project. But no results.

I am already totally desperate and any advices are welcomed. If I can provide any more information, just tell me what I should run or do and I will copy these information to my question.

This is my computer's information:

System:    Host ntb Kernel 3.2.0-4-amd64 x86_64 (64 bit) Distro Linux Mint Debian Edition

CPU:       Quad core Intel Core i7-2670QM (-HT-MCP-) cache 6144 KB flags (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips 17543.7
           Clock Speeds: (1) 800.00 MHz (2) 800.00 MHz (3) 800.00 MHz (4) 800.00 MHz (5) 800.00 MHz (6) 800.00 MHz (7) 800.00 MHz (8) 800.00 MHz

Graphics:  Card-1 Intel 2nd Generation Core Processor Family Integrated Graphics Controller Card-2 NVIDIA GF108 [GeForce GT 540M] X.Org 1.12.4 Res: 1600x900@60.1hz
           GLX Renderer N/A GLX Version N/A Direct Rendering N/A

Audio:     Card Intel 6 Series/C200 Series Chipset Family High Definition     Audio Controller driver snd_hda_intel BusID: 00:1b.0
           Sound: Advanced Linux Sound Architecture Version 1.0.24

Network:   Card-1 Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver r8169 v: 2.3LK-NAPI at port 3000 BusID: 04:00.0
           Card-2 Intel Centrino Wireless-N 1030 driver iwlwifi v: in-tree: BusID: 02:00.0

Disks:     HDD Total Size: 750.2GB (-) 1: /dev/sda ST9750420AS 750.2GB

Partition: ID:/ size: 49G used: 7.6G (17%) fs: rootfs ID:/ size: 49G used: 7.6G (17%) fs: ext4

Sensors:   System Temperatures: cpu: 65.0C mobo: 65.0C
           Fan Speeds (in rpm): cpu: N/A 

EDIT: Ever since I asked this question I, time to time, tried to look for some complex solution to this problem. Eventually I hit on THIS absolutely perfect answer that helped me solve all my troubles with overheating and fan noise. Just follow the instructions and you will be fine. Especially I recommend using indicator-cpufreq.

share|improve this question
    
"Loud fan" is typically obstructed airflow, possibly caused by shovelfulls of dust in the machine; or bearings giving out. –  vonbrand Feb 9 '13 at 16:31
    
Machine is 2 months old and it is doing ever since I have bought it. I do not think, that there is a problem. –  Jendas Feb 9 '13 at 22:06
add comment

2 Answers

up vote 2 down vote accepted

The nvidia drivers will not affect the fan. You might want to not use the NVidia card though. The integrated graphics card will give out less heat. In fact, I would disable the dedicated card in the BIOS, you almost certainly do not need it.

In any case, what you will need is to install i8kutils. This package will install certain modules and programs that are specific for Dell fans.

sudo apt-get install i8kutils 
modprobe i8k
i8kfan 0 1 

You can play with i8kfan to see that the settings are correctly read and applied. If it does, add i8k to /etc/modules.

You should also choose the ondemandCPU scaling governor. The governor controls CPU frequency scaling. Your choices are:

  • Performance keeps the CPU at the highest possible frequency
  • Powersave keeps the CPU at the lowest possible frequency
  • Userspace exports the available frequency information to the user level (through the /sys file system) and permits user-space control of the CPU frequency
  • Ondemand scales the CPU frequencies according to the CPU usage (like does the userspace frequency scaling daemons, but in kernel)
  • Conservative acts like the ondemand but increases frequency step by step

With ondemand, your CPU will only run at its highest speed when necessary. Ideally, this will be completely transparent for you, you machine will simply work as fast as necessary for the current tasks. To activate it do

sudo echo ondemand > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
share|improve this answer
    
I really appreciate your answer and the ondemand setting really helped significantly but I had some difficulties with the i8kutils. I did some "experiments" with it but eventually the computer got always totally stack after tries to reset fan values. SO I want to ask you, is that fan package any use for me besides the fact I can manually regulate the fan speed? –  Jendas Feb 10 '13 at 9:01
    
@Jendas, what happens if you load the i8k module and don't use i8kfan? The fan should be correctly regulated. –  terdon Feb 10 '13 at 12:25
    
@Jendas I just noticed I had a mistake in my original answer, the module you should add to /etc/modules is i8k not i8kfan. –  terdon Feb 10 '13 at 13:05
add comment

I had the same problem. My fan was working like hell all the time. I tried with everything in Linux but nothing happend. So my conclusion was that my second graphic card is overheating and makes fan work all the time. I have two graphic cards, an Intel HD and nVidia 635. I was trying to remove nVidia from the system but it was booting every time again and again with it on. Because to put nVidia drivers was really f.u. and Linux just went berserk, so I entered BIOS and turned off the nVidia and just let the Intel card work and now it is okay. I cannot make only nVidia work from the BIOS (maybe if I upgrade it). So Linux uses Intel, and for Windows 7 I turn on both cards so I can use nVidia for some apps that I need.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.