Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm fairly new to tmux and to truly master and learn it, I decided to make myself a fresh .tmux.conf

I was wondering, though, if it's possible to hide a path in the status bar.

For example, I have this in my tmux.conf:

setw -g window-status-format '#I #10W'
setw -g window-status-current-format '#[fg=red][#I:#10W]#F'

Now, let's use my window as an example.

In one window, I have macvim running. The tmux status bar changes to "[1:mvim]". That's exactly what I want. But I have another pane inside that window running ttytter. When I switch to it, tmux doesn't change the name to "1:[ttytter]"

Also, in another window, I have opened a directory with a long path name. tmux changes the status bar to "[1:...long/path]*". I've seen people run their tmux and it only says "zsh" for them. How can I have that too? I don't want the full path name inside my status bar.

I'm running tmux on OS X if that helps.

Thanks in advance for any help!

share|improve this question

1 Answer 1

I answered my own question.

I'm really happy about this since I've been trying to get it like that and it was such a simple fix.

I was actually using prezto, the zsh framework and in my ~/.zpreztorc, I forgot I set it to autotitle my terminal tabs/windows.

So I changed: zstyle 'prezto:module:terminal' auto-title 'yes' to zstyle 'prezto:module:terminal' auto-title 'no'

and the problem goes away. There are a lot of options in the modules you can set as well. If anyone is running prezto, I recommend reading the terminal module readme and researching what the module actually does.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.