Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have mybb installed and running in /var/www/forums.

I have two users part of the www group, logan and www-data.

I have the recursive permissions of forums directory set to:

chmod -R 755 forums
chown -R www-data:www forums

I have vsftpd set to write-enable=YES.

I can't upload a file! I get this on my filezilla:

    Status:  Starting upload of C:\Users\l162student\Desktop\money.png
    Command:    PASV
    Response:   227 Entering Passive Mode (174,102,254,169,249,243).
    Command:    STOR money.png
    Response:   553 Could not create file.
    Error:  Critical file transfer error

If you need any log files or conf files just ask.

UPDATE: I just tried 775 and it lets me write files, BUT... The files are all:

Owner Group  33 1005  -rwxrwxr-x

and the new files I upload are showing up as only:

Owner Group  1000 1005  -rw-r--r--

I want new files to INHERIT the folders permissions OR just show up as:

Owner Group  33 1005  -rwxrwxr-x

How can I do this?

share|improve this question
    
What your distribution? –  warl0ck Feb 9 '13 at 2:57
    
root@Citation:/var/www# cat /etc/*-release DISTRIB_ID=Ubuntu DISTRIB_RELEASE=12.04 DISTRIB_CODENAME=precise DISTRIB_DESCRIPTION="Ubuntu 12.04.2 LTS" NAME="Ubuntu" VERSION="12.04.2 LTS, Precise Pangolin" ID=ubuntu ID_LIKE=debian PRETTY_NAME="Ubuntu precise (12.04.2 LTS)" VERSION_ID="12.04" root@Citation:/var/www# –  logo3801 Feb 9 '13 at 3:05
    
Basically to get it to "work" how I want it too I have to ssh in after each upload and chmod -R 775 forums so annoying and I just want it to work correctly... –  logo3801 Feb 9 '13 at 3:07
    
Want a guide for ACL on Ubuntu? –  Christopher Feb 9 '13 at 3:17
    
Sure, send away just don't want something complicated, also since I have posted this, I have gotten it to work. The Solution is the vsftpd config umask.... I don't know how I missed this. –  logo3801 Nov 21 '13 at 19:02

2 Answers 2

Using umask in the FTP config sets the Permissions on uploaded files, really what needed to be done was just setting users and groups properly. Admin/mod you may delete this question.

share|improve this answer
    
If you want a question deleted you can flag it for a moderators attention, or with enough rep cast a close vote on it. However, the purpose of SE sites is to have questions and answers for them, so even though you solved your problem the larger purpose is so that others with the same problem may find your answer and benefit from it. With that said, welcome to Unix&Linux Stack Exchange. –  casey Feb 6 at 21:25

In this file: /etc/vsftpd/vsftpd.conf:

#umask=002

Problem solved!

share|improve this answer
    
Please expand this answer. Though it might be the solution, it's doesn't really explain how in much detail. –  slm Nov 21 '13 at 19:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.