Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using mutt-1.5.21p0v0 to read my mail on OpenBSD 5.2 every now and then.

Why does mutt show question marks instead of Cyrillic characters when I open standards-compliant email messages in Russian?

share|improve this question
1  
Console or X11? –  Jiri Xichtkniha Feb 8 '13 at 8:30
    
PuTTY; but the problem is specifically with mutt -- for example, cat shows Cyrillic symbols in koi8-r just fine, without any problems. It's mutt that seems to automatically translate all non-ascii characters to the ascii character of ?. –  cnst Feb 8 '13 at 18:39

1 Answer 1

http://dev.mutt.org/trac/wiki/MuttFaq/Charset

You have to decide on a locale and a character set.

For a list of locales and their corresponding character sets, see /usr/share/locale/ on OpenBSD. There is no mix-and-matching between languages and charsets, apart from what's in that directory. However, the language and charset are controlled by LANG and various more specific LC_ environmental variables, which can be set independent of each other to potentially have the exact effects desired.

In order to just change the character set, and not the language of the menus or any other options, only LC_CTYPE has to be modified. For example, in PuTTY WindowTranslation, set Remote character set to either KOI8-R or UTF-8, and then run mutt as either env LC_CTYPE=ru_RU.KOI8-R mutt or env LC_CTYPE=en_US.UTF-8 mutt (assuming a C-shell), respectively.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.