Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Just a few minutes ago my sound was working, and then it stopped! I suspect it was caused by me checking out some video editors. How do I go about troubleshooting this?

What I've so far tried:

  • I ran lsof | grep audio and lsof | grep delete to see if there's any process locking the audio path(?), but nothing looks suspect.
  • VLC and MPlayer are affected, while Quod Libet (GStreamer) isn't.

[update] Strange one. I don't know if it has anything to do with Quod Libet, but I noticed that after closing (and reopening) it, the problem seemed to disappear. Note that I haven't logged out yet.

share|improve this question
maybe try deleting weird settings in your home? – phunehehe Jan 25 '11 at 1:33
@phu I didn't change any settings. – Tshepang Jan 25 '11 at 1:34
and what did you expect to see with lsof | grep delete? – alex Jan 25 '11 at 6:31
@alex I was checking if there was some old proces still holding onto the audio device, blocking others from accessing it. – Tshepang Jan 25 '11 at 6:53
and what that 'delete' thing has to do with that? – alex Jan 25 '11 at 7:13

You might try logging out of your desktop and logging back in. Sometimes this is enough to kill any locks, delete tmp files, reset any other configuration gizmos that might have gotten left by a mis-behaving application. You might also try poking through the Sound Preferences configuration for the hardware selections and make sure that your selected output hardware looks correct.

Knowing which distro you're using might help in getting more suggestions.

share|improve this answer

It might be because of pulseaudio. Try killing it and rerunning the application.

share|improve this answer
This could be it, because I installed it as well. But then I didn't even stop it, and the problem went away. – Tshepang Jan 25 '11 at 13:29

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.