Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've recently switched to using Slackware 14 on my laptop, so far I'm quite happy with the distro, except for 1 really annoying little thing: I can surf using hotspots, and all sorts of public wifi-access-points, but I can't seem to get on-line at home.

Prior to running Slackware, I was using Debian, so yes, my laptop has been on my home network, without mac-spoofing or anything.
Currently, I've setup my wlan interface as eth1, and added these lines in my /etc/rc.d/rc.local:

wpa_supplicant -B -Dwext -ieth1 -c/etc/wpa_supplicant.conf

Which does the trick, it seems, using something like wpa_cli or wpa_gui, I can easily connect to my home network.
I therefore changed the wpa_supplicant file a bit, adding:

network={
    ssid="HomeSweetHome"
    psk=0123464sdasd4d56agr6 #output from wpa_passpharse HomeSweetHome mypassphrase
    key_mgmt=WPA2-PSK #and so on
}

But no matter what I do (use settings above, or connect manually) I can connect to other machines on the LAN, but as soon as I try to google something, nothing happens. Constantly "Waiting for siteX" is all I get.

Does anybody here have any idea as to what I'm missing here? There has to be something I haven't configured as supposed to here... I can't think of anything ATM, though.

Update:

Yes, I can ping 8.8.8.8, no problem. I can add network locations and share files with the other computers in the network, too.

Output of ifconfig eth1:

eth1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.64  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::213:ceff:fef1:5267  prefixlen 64  scopeid 0x20<link>
        ether 00:13:ce:f1:52:67  txqueuelen 1000  (Ethernet)
        RX packets 491  bytes 57950 (56.5 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 75  bytes 10228 (9.9 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 17  base 0x6000  memory 0xdfcff000-dfcfffff  

Output of route -n:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    303    0        0 eth1
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
192.168.1.0     0.0.0.0         255.255.255.0   U     303    0        0 eth1

ping google.com: All went well, 0% packet loss, on average 20ms/packet.

tcptraceroute isn't installed at the moment, but I'll set it up in due time. For now, here's the output of traceroute -n 8.8.8.8

traceroute 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
 1  192.168.1.1  1.190 ms  1.872 ms  5.465ms
 2  192.168.0.1  5.520 ms  5.699 ms  6.960 ms
 3  78.21.0.1  15.007 ms  15.850 ms  17.525 ms
 4  * * * *
 5  213.224.253.9  27.151 ms  28.096 ms  28.146 ms
    # And so on, all the way to:
12  * * * *
13  8.8.8.8  17.921 ms  22678 ms  20.022 ms
share|improve this question
2  
When at home, after connecting to wifi, (1) Can you ping 8.8.8.8? (2) Post output if ifconfig (3) Post output of route -n –  John Siu Feb 7 '13 at 2:17
    
@JohnSiu: added additional info –  Elias Van Ootegem Feb 7 '13 at 9:33
    
One more question, can you ping google.com? –  John Siu Feb 7 '13 at 10:34
    
Please post the output of tcptraceroute google.com 80, or if you can't easily install tcptraceroute then at least traceroute -n 8.8.8.8. –  Gilles Feb 7 '13 at 23:24
    
@JohnSiu: Ping google works just fine, added abbreviated output of traceroute -n 8.8.8.8 to the question, too –  Elias Van Ootegem Feb 8 '13 at 11:42

1 Answer 1

up vote 0 down vote accepted

Damn, do I feel stupid right now. Like I said in the question, I've added:

network={
    ssid="HomeSweetHome"
    psk=0123464sdasd4d56agr6
    key_mgmt=WPA2-PSK #and so on
}

To the wpa_supplicant.conf file, what I should've done is just add the raw output of wpa_passphrase HomeSweetHome mypasspharse to the file, not bothering with manually adding settings like key_mgmt and others. Everything is working just fine with this:

network={
    ssid="HomeSweetHome"
    # psk="mypassphrase"
    psk=0123464sdasd4d56agr6
}

Thanks for the time, hope this helps somebody else in the future, and please forgive my blind idiocy here...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.