Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a Dell Studio 1450 running Fedora 17. I installed a new wireless router in the office recently. And everybody apart from me is able to connect to the internet via it. Google revealed http://forums.fedoraforum.org/showthread.php?t=276645 which is very similar to my problem. Here are output logs of some commands for you to help me.

$ ifconfig wlan0
wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.11.5  netmask 255.255.255.0  broadcast 192.168.11.255
        inet6 fe80::222:fbff:febd:a1d4  prefixlen 64  scopeid 0x20<link>
        ether 00:22:fb:bd:a1:d4  txqueuelen 1000  (Ethernet)
        RX packets 217025  bytes 207399872 (197.7 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 140947  bytes 22960122 (21.8 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

$ ping -c 3 192.168.11.1
PING 192.168.11.1 (192.168.11.1) 56(84) bytes of data.
^C
--- 192.168.11.1 ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 1999ms

$ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.11.1    0.0.0.0         UG    0      0        0 wlan0
192.168.11.0    0.0.0.0         255.255.255.0   U     0      0        0 wlan0

$ cat /etc/resolv.conf 
# Generated by NetworkManager
nameserver 192.168.11.1
nameserver 192.168.1.1

Regards

EDIT 1: outputs from other machine running Linux Mint, normally working on the network.

$ ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr e0:ca:94:8a:f4:08  
          inet addr:192.168.11.2  Bcast:192.168.11.255  Mask:255.255.255.0
          inet6 addr: fe80::e2ca:94ff:fe8a:f408/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:795989 errors:0 dropped:0 overruns:0 frame:0
          TX packets:729687 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:871899683 (871.8 MB)  TX bytes:83227427 (83.2 MB)


$ ping -c 3 192.168.11.1
PING 192.168.11.1 (192.168.11.1) 56(84) bytes of data.
64 bytes from 192.168.11.1: icmp_req=1 ttl=64 time=1.12 ms
64 bytes from 192.168.11.1: icmp_req=2 ttl=64 time=1.17 ms
64 bytes from 192.168.11.1: icmp_req=3 ttl=64 time=1.12 ms

--- 192.168.11.1 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 1.123/1.139/1.172/0.035 ms


$ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.11.1    0.0.0.0         UG    0      0        0 wlan0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlan0
192.168.11.0    0.0.0.0         255.255.255.0   U     2      0        0 wlan0


$ cat /etc/resolv.conf
cat: /etc/resolv.conf: No such file or directory

UPDATE: It is not a problem with fedora, it is my laptop. I tried with other distros (Ubuntu 12.04 anh Bodhi Linux) and the same problem exists.

share|improve this question
    
One quick thing to try - get the same output from one of your colleagues' machines... –  Rory Alsop Feb 6 '13 at 10:05
add comment

2 Answers

Anurat - Try assigning a static IP address instead of getting it from DHCP to your wireless interface and ping the gateway. Your router might be blocking traffic from a certain IP range. In particular, try to use an IP address assigned to another client in your network that has Internet access.

share|improve this answer
    
Great idea. Usurping the IP address used by somebody else won't work while they are using it, and will block their use if you come "first". –  vonbrand Feb 11 '13 at 3:44
add comment
up vote 0 down vote accepted

It was a problem with my hardware. The new router was running an 802.11n network while Intel WiFi link 5100 card in my Dell Studio 1450 doesn't support it. Other laptops in the office being comparatively newer were operating perfectly.

Solution: Changed router settings to run on b/g mode and everything is back in order now.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.