Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Im trying to run a yum update but getting stopped by dependencies. I have installed rpmforge el6 which i need for other packages.

Error: Package: perl-IO-Compress-2.052-1.el6.rfx.noarch (rpmforge-extras)
           Requires: perl(Compress::Raw::Zlib) = 2.052
           Installed: 1:perl-Compress-Raw-Zlib-2.020-127.el6.i686 (@base)
               perl(Compress::Raw::Zlib) = 2.020
           Available: perl-Compress-Raw-Zlib-2.030-1.el6.rfx.i686 (rpmforge-extras)
               perl(Compress::Raw::Zlib) = 2.030
           Available: perl-Compress-Raw-Zlib-2.033-1.el6.rfx.i686 (rpmforge-extras)
               perl(Compress::Raw::Zlib) = 2.033
           Available: perl-Compress-Raw-Zlib-2.034-1.el6.rfx.i686 (rpmforge-extras)
               perl(Compress::Raw::Zlib) = 2.034
           Available: perl-Compress-Raw-Zlib-2.035-1.el6.rfx.i686 (rpmforge-extras)
               perl(Compress::Raw::Zlib) = 2.035
           Available: perl-Compress-Raw-Zlib-2.037-1.el6.rfx.i686 (rpmforge-extras)
               perl(Compress::Raw::Zlib) = 2.037
           Available: perl-Compress-Raw-Zlib-2.051-1.el6.rfx.i686 (rpmforge-extras)
               perl(Compress::Raw::Zlib) = 2.051
           Available: perl-Compress-Raw-Zlib-2.052-1.el6.rfx.i686 (rpmforge-extras)
               perl(Compress::Raw::Zlib) = 2.052
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

[root@mx2 ~]# yum install perl-Compress-Raw-Zlib-2.052-1.el6.rfx.i686
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centosn4.centos.org
 * extras: mirror.nsc.liu.se
 * rpmforge: mirror.nl.leaseweb.net
 * rpmforge-extras: mirror.nl.leaseweb.net
 * updates: centoss5.centos.org
Setting up Install Process
Package matching perl-Compress-Raw-Zlib-2.052-1.el6.rfx.i686 already installed. Checking for update.
Nothing to do

[root@mx2 ~]# perl -MCPAN -e shell
Terminal does not support AddHistory.

cpan shell -- CPAN exploration and modules installation (v1.9800)
Enter 'h' for help.

cpan[1]> install Compress::Raw::Zlib
CPAN: Storable loaded ok (v2.20)
Reading '/root/.cpan/Metadata'
  Database was generated on Tue, 05 Feb 2013 10:41:03 GMT
Compress::Raw::Zlib is up to date (2.060).
share|improve this question

2 Answers 2

The 1: before the package name on the installed package means that it has an epoch of 1. The absence of this on the available packages means that they have an epoch of 0. Higher epoch values will trump higher version and release values, hence you will either have to downgrade to 0:2.052 and pin the package version, or RPMForge will have to fix their packages by bumping the epoch to 1 and rebuilding.

share|improve this answer
    
aw! poo! I will have to write to the package maintainer as @schaiba suggested –  Christian Feb 5 '13 at 12:01
    
Did you manage to contact the maintainer? I am still getting this crap error. –  giorgio79 Feb 8 '13 at 7:27
    
No. I couldn't figure out how to. So in the interim, I have added under [rpmforge-extras] in /etc/yum.repos.d/rpmforge.repo exclude=perl-IO-Compress* –  Christian Feb 16 '13 at 13:47

Try Removing the Conflicting Package by running

yum remove perl-Compress-Raw-Zlib

Run

yum update

This issue comes from RPM Forge Extra Repository with Version Mismatch.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.