Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am a linux noob trying to optimize John the Ripper for a security class. I am trying to use both processors to run John by using the mpirun program as suggested in this tutorial. I installed mpirun, but when I run this command, I get the following error:

# sudo mpirun -np2 /usr/share/john --test=10 
/usr/bin/mpirun: 1: eval: usr/share/john: Permission denied.

Why am I getting this error and how can I run John with two processors using mpirun? I am running Ubuntu 12.10 on a VMware Fusion machine on a Mac with an Intel Core i5

share|improve this question
    
You can also compile John with OpenMP, which speeds up certain hash types. The jumbo patch includes OpenMP support and many more optimizations and hash types: github.com/magnumripper/JohnTheRipper –  bonsaiviking Feb 4 '13 at 15:15
add comment

1 Answer

/usr/share/john is probably not the path to the binary, but to the folder containing application specific data.

Try

sudo mpirun -np 2 /usr/sbin/john --test=10 

instead.

share|improve this answer
    
Thanks. When I ran that command I got an error saying john.ini is missing. I copied the john.ini file. Now when I run the command that you suggest from root, I get: Unrecognized argument -np2 ignored. Any suggestions? –  akh2103 Feb 4 '13 at 13:47
    
There is a space missing after -np. I updated my answer. –  jofel Feb 4 '13 at 14:29
    
And you can call john as normal user, you do not need sudo. –  jofel Feb 4 '13 at 14:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.