Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm installing Gentoo as a guest on a VMware virtual machine on an iMac host. I'm asked to select a profile and the list has 22 options.

[1]  default/linux/amd64/10.0
[2]  default/linux/amd64/10.0/selinux
[3]  default/linux/amd64/10.0/desktop
[4]  default/linux/amd64/10.0/desktop/gnome
...
[7]  default/linux/amd64/10.0/no-multilib *
...
[10] default/linux/amd64/13.0
...

Currently the 10.0/no-multilib profile is selected.

I'm intending to use the virtual machine for experimenting, web browsing, running things that the Mac doesn't offer or that I don't want to install permanently.

I will probably run neither Gnome nor KDE but a lightweight WM. I am inclined to select the 'desktop' profile, but which should I use, 10 or 13 (and what happened to 11 and 12)? What do the 10/13 mean? They don't seem to correspond to a Gentoo 'version'.

I've got the no-multilib profile currently because I downloaded the nm stage3. Perhaps I should stick with the no-multilib profile and adjust the USE flags?

share|improve this question
    
multilib is still required by many applications –  frostschutz Feb 3 '13 at 13:19

3 Answers 3

up vote 1 down vote accepted

I would select the latest version vanilla desktop profile. That shows 12 on my system (using eselect profile list).

share|improve this answer
    
Thanks, I followed your advice. –  William Morris Feb 3 '13 at 23:34

I would recommend against 'no-multilib' as many programs require that. If you are following along with the Gentoo handbook you should see that the 'Desktop' profile is recommended for most users. You should therefore use the latest 'Desktop' profile which is:

default/linux/amd64/13.0/Desktop

I believe the numbers are legacy and refer to yearly live media (this is complete speculation), though Gentoo's release model is rolling.

In any case I had no problems installing a functioning system with */13.0/Desktop

share|improve this answer
    
Thanks. I already went ahead with the 10.0/Desktop, which completed successfully. I noticed somewhere that the 10.0 ones are mostly marked 'stable' and the 13.0 ones are marked 'dev'. So I went with the stable ones. Since then I've done a full update command and it is now busy merging 194 packages - so perhaps I end up with the 13.0 situation - or perhaps not. –  William Morris Feb 3 '13 at 23:33

See this blog post for more information:

http://dilfridge.blogspot.de/2013/02/gentoo-100-to-130-profiles-upgrade.html

share|improve this answer
1  
Please summarize a bit why this link is relevant. –  vonbrand Feb 9 '13 at 12:37
    
Thanks, that was what I wanted. Sadly, I had so many problems installing (last straw I think was firefox failing to merge) that I gave up and install debian instead. –  William Morris Feb 9 '13 at 15:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.