Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I want to install the latest version of ffmpeg on Linux (Ubuntu/Debian). It should meet requirements to stream via rtmp, convert streams with x264, create segment files to stream to IOS devices. How would I go about doing that?

share|improve this question

migrated from stackoverflow.com Feb 2 '13 at 23:55

This question came from our site for professional and enthusiast programmers.

1 Answer 1

The FFmpeg wiki has a compilation guide for Ubuntu. There's also one for CentOS. Since the guides are constantly updated for future releases, there is no point in copying all the information here.

When following the Ubuntu guide, you will install the following additional encoders from source:

  • x264: you need this for streaming
  • fdk-aac: this provides way better quality AAC than the FFmpeg-native AAC encoder
  • vpx: for WebM streaming you should install this as well
  • opus: purely optional, not needed

With the CentOS guide, the following are manual installs in addition to the ones mentioned above:

  • LAME: this is the MP3 encoder you should use
  • libogg and libvorbis: for Theora video and Vorbis audio

Instead of manually compiling FFmpeg, you can also download a static build from the homepage. These are Git snapshots, so they're always fresh. The static builds don't include ffserver by the way.

Note: For licensing reasons they can't bundle FAAC or FDK-AAC. They do include libvo-aacenc, but it also doesn't give you any better quality than the native AAC encoder in FFmpeg.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.