Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

After replacing the motherboard, which is the same as after replacing the network adapter interface hardware (NIC), our Debian 6.0.6 no longer loads the networking driver on boot.

The manual approach succeeds:

# rmmod e1000e
e1000e 0000:03:00.0: PCI INT A disabled
# modprobe e1000e
e1000e: Intel(R) PRO/1000 Network Driver - 2.1.4-NAPI
e1000e: Copyright(c) 1999 - 2012 Intel Corporation.
e1000e 0000:03:00.0: Disabling ASPM L0s L1
e1000e 0000:03:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
e1000e 0000:03:00.0: setting latency timer to 64
e1000e 0000:03:00.0: Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode
e1000e 0000:03:00.0: irq 27 for MSI/MSI-X
e1000e 0000:03:00.0: irq 28 for MSI/MSI-X
e1000e 0000:03:00.0: irq 29 for MSI/MSI-X
e1000e 0000:03:00.0: eth0: (PCI Express:2.5GT/s:Width x1) 00:25:90:7c:b8:ec
e1000e 0000:03:00.0: eth0: Intel(R) PRO/1000 Network Connection
e1000e 0000:03:00.0: eth0: MAC: 4, PHY: 8, PBA No: FFFFFF-0FF
udev[682]: renamed network interface eth0 to eth2

We have tried to:

  1. Update the driver (our initial driver version was the one in the kernel: 1.2.20-k2): no improvement
  2. Adding pcie_aspm=off kernel parameter on boot: no improvement
  3. Adding e1000e to your /etc/modprobe file to ensure it's loaded on boot: no improvement
  4. Adding an alias line to /etc/modules.conf and /etc/modprobe.conf: no improvement

How to make the network kernel module load again on boot?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

After replacing the networking interface card, there will remain old entries in /etc/udev/rules.d/70-persistent-net.rules.

The solution is to remove the lines containing the old MAC addresses in this file, in our case there were 3 lines that could be removed, reboot and bingo.

The e1000e is now correctly loaded again: networking fixed.

Thanks to: http://linuxadmin.com.pl/replacing-network-interface-card-nic-in-ebian5-os/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.