Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to install Linux Mint (Cinnamon) from a CD. It will act like it is loading for a while, the CD drive will make a ton of noise for a while, and then everything just freezes (the CD drive will go silent). I tried this a few times and then started in compatibility mode. Every time, I get the following:

failed to load file amd-ucode/microcode_amd.bin

I'm trying to install on an older Toshiba Satellite laptop (with Ubuntu currently installed). Any ideas on a fix ?

share|improve this question
3  
It's possible that the CD is damaged. Or even worst, the CD drive. Try it on a different computer and with a different CD if possible. –  Martín Canaval Feb 2 '13 at 17:17
    
The CD worked on several other computers, so it may well be the drive. I tried booting from USB, but the laptop will not even read the USB. –  user31649 Feb 3 '13 at 4:57
    
@5space, it might have worked and gotten scratched later, or your Toshiba's CD drive is pickier than the others. Clean the CD, carefully clean the lens of the drive (it shows when you eject the empty drive). Check the installation media. Download, check, and burn a new copy, at a slow speed. –  vonbrand Feb 5 '13 at 15:23

1 Answer 1

This is a common defect in newer mint & ubuntu versions. It doesn't have the correct AMD & intel drivers & controllers for many computers. Use an older version or a different linux. It will even fail on a live install on windows on the same machine. I find Debian versions easily install on machines that mint & ubuntu hang, freeze, & fail on.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.