Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm running Solaris 8 on a Sun Ultra 2 connected to a Verizon router. nslookup seems to work (it finds google.com) but the existing browser (Netscape 4.76 - yes - it's very old) fails to reach any web page "Unable to connect to server (TCP Error. Network is unreachable)".

Obviously I'm a novice when it comes to these connectivity issues. Any help will be appreciated.

share|improve this question
    
If it's "TCP Error. Network is unreachable" then it's probably not a name resolution problem. Check your default route and your network connectivity in general. Can you telnet to google.com on port 80 from the command line? –  Celada Feb 1 '13 at 16:48
    
OK, telnet fails. nslookup yielded several IP addresses. Attempting to telnet appears to try each and the result is host not reachable. –  Tom Feb 1 '13 at 23:42
    
So it's a network reachability problem... but there is not enough information here to guess at the cause. –  Celada Feb 1 '13 at 23:48
    
Have you tried using traceroute to some of those IP addresses to see where the failure occurs? –  alanc Feb 2 '13 at 5:36
add comment

1 Answer

Did you install Solaris on this machine? If not, is it possible there's a previous network connection that could be complicating matters? Is it set to use DHCP and that's where the DNS servers are being set your router should be set too, but maybe an old IPFilter config is interfering, or more than 1 default router is interfering?

It seems strange, given that DNS is working. To me that sounds like a default router issue, and that possibly DNS is working because the Verizon router is the DHCP dns server, and since it's on the local network, it's reachable even without the default route working. Use netstat to check your default route (netstat -rn), and if you don't have one, add your verizon router as the default router (route add default 192.168.1.1) (or whatever the IP of your router is). Make it persistent by putting that IP in /etc/defaultrouter. If you want, you can add the IP and name to /etc/hosts, and put the name /etc/defaultrouter.

If you have more than one, delete the one you don't need (route delete default 192.168.1.1) or whatever the IP is of the router you want to remove, and make sure it's not persistent in /etc/defaultrouter.

If you have an old IPfilter command running, you could try stopping it via the init script (find the init script with: find /etc/inet.d -name \*ipf\*) and run /etc/inet.d/$ipfscript stop. If you want to disable it completely, but keep it around with the intention of learning ipfilter at a later date, you can add exit 0 to the second line of the init script. that will keep it there, but stop it from loading at boot.

If you want to remove it altogether, you'll need to find the package name for it (pkginfo | grep -i ipf) then you can pkgrm $ipfpkg.

share|improve this answer
    
OK - your response has made the difference. The defaultrouter setting was bad. I've had this system for quite a few years but never had time to try to use it. The OS was installed at least 10 years ago. I got it when the company I was working for closed the site. I'm retired now and I'm hoping to make use of this thing. –  Tom Feb 2 '13 at 21:10
    
Any idea if I could install a DVD ROM in this Ultra 2? It seems thats the only way I could upgrade to Solaris 10 (Solaris 11 isn't built for the Ultra 2). Solaris 10 is only available on a DVD. –  Tom Feb 2 '13 at 21:12
    
Thanks again for your help. –  Tom Feb 2 '13 at 21:13
    
Solaris 10 will work just fine, and yes, if you can find a SCSI CD-ROM drive, you can install Solaris 10 that way. Another way might be to set up a jumpstart server on another computer and install Solaris 10 that way. –  Tim Kennedy Feb 3 '13 at 4:33
    
This box already has a CD-ROM drive, but I don't think Solaris 10 is available on CD; only on DVD. I have a DVD image I could I could use. I'll have to look into how to set up a jumpstart server. –  Tom Feb 3 '13 at 15:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.