Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm writing a shell script that needs to send an 8 character string terminated with a x0d to a Sharp Aquos TV. An example is 'POWR1 \x0d' (POWR1 followed by three spaces and LF)

The documentation is poor. it says protocol TCP/IP (nothing about UDP or TCP) and service: nothing: do not select telnet or SSH.

In the past, for similar projects I've been able to use socat and something like:

echo -e -n 'POWR1   \x0d' | socat - tcp4:192.168.1.88:10002

However, all I get is "socat[3875] E connect(3, AF=2 192.168.1.88:10002, 16): Connection refused"

Anyone got any ideas

share|improve this question
1  
I usually use netcat (nc) the same way - but if the remote refuses the connection even before you send anything, it doesn't really matter what you use. You have to make the remote server to accept your connections first. –  frostschutz Jan 31 '13 at 20:15
add comment

3 Answers

Displays with network control features often ship with the feature disabled. Look in the manual to see if there is a way to enable it.

I would have done the manual diving for you, but you don't give a model number.

share|improve this answer
add comment

Maybe info from this post will help.

Enable IP on TV set

... I allowed the Sharp to controlled using the Network settings tab on the TV and also set up a static IP. All internet stuff on the TV works fine ...

share|improve this answer
add comment

I have working solution for you. You need to:

Open Menu -> Settings -> View Settings -> Network Settings -> IP control Settings -> ChangeSet your tv name, username, password, port

After that you can send your commands so:

echo -e -n 'user\x0dpassword\x0dIAVD4   \x0d' | \
        socat - tcp4:192.168.100.113:10002

NOTE: for the above: (user/pass/ip/port insert with your values)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.