Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Had been running smoothly for a while in Slackware 14 on my laptop, did full install with KDE,then after installing Tor and Vidalia, the Vidalia icon stopped working, so I restarted the computer.

For my primary user, startx was no longer recognized as a command.

I was still able to startx from root, so then I made a user test using all defaults and startx works here too... though after reboot, startx is also "not found" for test.

echo $PATH startx for the user:

/usr/local/bin:/bin:/usr/bin startx

echo $PATH startx for the superuser (su -l):

/usr/local/sbin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/lib/kde4/libexec:/usr/lib/qt/bin:/usr/share/texmf/bin startx

I have also tried copying .Xauthority from root to the user, but to no avail. Another thing I tried was setting x to start using init scripts, but when it booted x, and I attempted to log in as user, it ignored my command until I logged in as root

share|improve this question
    
Check your user's path and make sure the location of startx (/usr/bin) is there. Compare the paths of the test user with your user's. –  schaiba Jan 31 '13 at 17:41
    
If it is a matter of paths or permissions, you will get an explicit comment about "command not found" or "permission denied". If that's not what happened, startx may available, but there is an issue with configuration for that user. –  TAFKA 'goldilocks' Jan 31 '13 at 17:45
    
Have you tried visudo and add test ALL = (root, test) ALL to the file, so that you can sudo as root from your test user... In case you're not familiar with the site here's all you need to know on the sudoers file –  Elias Van Ootegem Mar 13 '13 at 0:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.