Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to compile the latest version of XBMC on CentOS 6 x64 but on ./configure I get:

checking for TAGLIB... no
configure: error: Could not find a required library. Please see the README for your platform.

I tried compiling the taglib coming with XBMC and also downloading the latest version from github. Both compile just fine but the error remains.

[root@xbmc xbmc]# find /usr -name libtag*
/usr/local/lib/libtag.a
/usr/local/lib/libtag.so
/usr/local/lib/libtag_c.so.0
/usr/local/lib/libtag.so.1.12.0
/usr/local/lib/libtag.so.1
/usr/local/lib/libtag_c.so
/usr/local/lib/libtag_c.a
/usr/local/lib/libtag_c.so.0.0.0
/usr/lib64/libtag.so
/usr/lib64/libtag_c.so.0
/usr/lib64/libtag.so.1
/usr/lib64/libtag.so.1.6.1
/usr/lib64/libtag_c.so
/usr/lib64/libtag_c.so.0.0.0
/usr/lib/libtag.so
/usr/lib/libtag_c.so.0
/usr/lib/libtag.so.1.12.0
/usr/lib/libtag.so.1
/usr/lib/libtag_c.so
/usr/lib/libtag_c.so.0.0.0

Any ideas how to fix that?

UPDATE
@slm

Package taglib-devel-1.6.1-1.1.el6.x86_64 already installed and latest version

These are the only options configure help lists regarding taglib:

 TAGLIB_CFLAGS  C compiler flags for TAGLIB, overriding pkg-config
 TAGLIB_LIBS linker flags for TAGLIB, overriding pkg-config
share|improve this question
    
git clone git://github.com/xbmc/xbmc.git –  Jim Jan 31 '13 at 17:12
add comment

3 Answers

  1. Remove "taglib 1.6" installed via yum.
  2. Compile and install taglib from Github in /usr.

    cmake -DCMAKE_INSTALL_PREFIX=/usr/
    
  3. Edit the xbmc configure script by changing ac_status=$? to ac_status=0 below the tests for a non-zero length of $TAGLIB_LIBS and $TAGLIB_CFLAGS:

    if test -n "$TAGLIB_CFLAGS"; then
      ac_status=0
    …
    if test -n "$TAGLIB_LIBS"; then
      …
      ac_status=0
    
share|improve this answer
    
In CentOS 6.4 i had to manually install cmake 2.8 as taglib 1.8 won't build with cmake 2.6 with some strange and cryptic errors: CMake Error at CMakeLists.txt:98 (file): file does not recognize sub-command COPY –  glebtv Jun 28 '13 at 19:40
add comment

Do you have the taglib and taglib-devel libraries installed. You typically need the -devel of a library in order to compile against it.

% yum search taglib
taglib.x86_64 : Audio Meta-Data Library
taglib-devel.x86_64 : Header files, libraries and development documentation for taglib.

Install like this:

% yum install taglib-devel

Also notice that taglib is installed under /usr/local. Depending on your system this area may not be on the path for applications to look for it, so the configure command you're using to build the makefiles for xbmc may require you specify this location with a --taglib=... type of switch.

Check with configure --help for more info when building xbmc for the specific value.

share|improve this answer
    
Read the readme for xbmc, I think you need taglib > 1.8. –  slm Jan 31 '13 at 16:31
    
I updated the post. I know that I need 1.8 but the repos dont have it. And the manual build doesn't work. –  Jim Jan 31 '13 at 16:33
add comment

I've seen the same problem, and the problem is tag-lib version. You have 1.6 and it requires 1.8. (check configure log). I cannot give you a solution cause I did not try anything, but "maybe", chnaging tag-lib version requirement solves compilation problem (not sure if 1.8 is really needed. Some XBMC developer should answer that.)

share|improve this answer
    
Sorry, did not see other replies... –  Arnau Feb 8 '13 at 17:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.