Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I want smb start with system. Do i have to place script that start smb in etc/rc.d/rc6.d/ or there is a way to make it listed in autostart services after #chkconfig smb on ? The question is why if i do as prescribed #chkconfig smbd on this help my for a few launches of system, and eventually samba daemon stops again?

# chkconfig --list

Note: This output shows SysV services only and does not include native
      systemd services. SysV configuration data might be overridden by native
      systemd configuration.

dund            0:off   1:off   2:off   3:off   4:off   5:off   6:off
livesys         0:off   1:off   2:off   3:on    4:on    5:on    6:off
livesys-late    0:off   1:off   2:off   3:on    4:on    5:on    6:off
netconsole      0:off   1:off   2:off   3:off   4:off   5:off   6:off
network         0:off   1:off   2:off   3:off   4:off   5:off   6:off
pand            0:off   1:off   2:off   3:off   4:off   5:off   6:off
rfcomm          0:off   1:off   2:off   3:off   4:off   5:off   6:off
spice-vdagentd  0:off   1:off   2:off   3:off   4:off   5:on    6:off 

this output don't change despite of chkconfig --level 5 smb on I need every start do in terminal #systemctl restart smb.service to get samba work one more circumstance i get this strange output

# ps aux |grep smb
root       859  0.0  0.1  25328  3184 ?        Ss   15:18   0:00 /usr/sbin/smbd
root       863  0.0  0.0  25844  1244 ?        S    15:18   0:00 /usr/sbin/smbd

when samba share don't work and after samba manual restart i get this

# ps aux |grep smb
root      1729  0.0  0.1  25328  3184 ?        Ss   15:26   0:00 /usr/sbin/smbd
root      1731  0.0  0.0  25844  1244 ?        S    15:26   0:00 /usr/sbin/smbd
nobody    1732  0.0  0.1  25632  3072 ?        S    15:27   0:00 /usr/sbin/smbd

a bit more info on subject

#systemctl list-unit-files --type=service |grep smb
smb.service                                 enabled 
# systemctl list-unit-files --type=service |grep avahi
avahi-daemon.service                        enabled 
# systemctl list-unit-files --type=service |grep nmb
nmb.service                                 enabled
#chkconfig --version
chkconfig version 1.3.59

To avoid mannualy typing each restart samba daemon start commands i made a desktop launcher for lxde fedora enviroment in ~/Desktop

[Desktop Entry]
Encoding=UTF-8
Type=Application
Name=mc
Name[en_US]=setsmb
Icon=share_32
Exec=/usr/bin/lxterminal -e "su root -c 'systemctl restart smb.service && systemctl restart nmb.service'"

I hope this help situation out as a crutch-solution for people in trouble with samba

share|improve this question
1  
Just a note, runlevel 6 is usually reboot and thus starting something in it won't do much good. Usually runlevels 0 and 6 just shut down everything. –  Michael Kjörling Jan 31 '13 at 15:09

1 Answer 1

Use the 'chkconfig' command to list the samba service automatically start on all runlevel.

[root@localhost ~]# chkconfig --list smb

The 'chkconfig' command below enable the samba server to start on runlevel 5.

[root@localhost ~]# chkconfig --level 5 smb on

Verify the configuration change.

[root@localhost ~]# chkconfig --list smb
share|improve this answer
    
this method i tried. Please look at my refurbished question. –  Yurij73 Feb 1 '13 at 11:30
1  
This bug has been fixed in chkconfig-1.3.52-1.fc15 (bugzilla.redhat.com/show_bug.cgi?id=693500). Updating chkconfig may solve it. –  sundeep Feb 1 '13 at 11:55
    
my chkconfig --version say that is 1.3.59 fc17 –  Yurij73 Feb 1 '13 at 17:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.