Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have installed Ubuntu 12.10 leaving Win 7 licensed version. But again as usual I need to fix so many issues.

This time fan is generating lots of noise. It looks it is running at max speed. My Laptop is becoming hotter than it usually was in the same period on Window.

I was looking for the solution and found the below:

sudo tee /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq </sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_min_freq

But I read that cpufreq is for cpu frequency. What to do now? I have already executed the command.

What is the solution for the problem of fan sound in Ubuntu 12.10 ? In win 7, this is not the problem.

My Laptop is Dell Studio 1555.

Update: I have noticed that even after using Ubuntu for an hr or so due to which my Laptop became hot, when I switch to Win 7, fan sound has reduced to half. The sound in Win 7 felt normal.

share|improve this question
    
Fans making almost any type of noise mostly means that the fan bearings are shot. It also could be too much dirt in the box, or something blocking airflow. –  vonbrand Jan 31 '13 at 23:09
    
@vonbrand Fans make airflow noises, even with perfect bearings. Especially high-RPM fans are noisy just from the airflow. –  derobert Feb 11 '13 at 14:55
1  
When you say it's becoming hotter, is that just an assumption from the fans running louder? Or is that from an actual temperature measurement (or at least feeling the heat with your hand)? If its actually running hot, that's the problem to solve... –  derobert Feb 11 '13 at 14:57
    
It is loudness of the fan as well as heat I feel when I touch Dell Studio laptop at the bottom. If I continue to use Ubuntu then my laptop life will be less. I edited grub so that I see ubuntu first in dual boot and many other things to use Ubnutu this time instead of win 7. –  Satya Prakash Feb 13 '13 at 12:55
    
In just 3 hrs it becomes hot enough that I feel the health of my laptop. Also at night time, fan sound is very irritating. It disturbs me. If anyone suggest me better well known Linux distro other than Ubuntu to which I can use easily then I can think of it. Fedora/mandrake/ ... ? –  Satya Prakash Feb 13 '13 at 13:04

5 Answers 5

I have a Dell and solved this with 'i8kutils'. It is just to configure 'i8kmon' for auto control. I hope it helps.

Just to left a note, the program 'dellfand' uses the same infrastructure as 'i8kutils', but is older. I found i8kutils much easier and well documented, and it has been updated recently. The page of development is below.

https://launchpad.net/i8kutils

share|improve this answer
    
Thanks for the info. But I got tired with Linux. Win 7 is just fine with cygwin. :) I may try different distros next time, if wish to have linux as main OS on my system again. –  Satya Prakash Nov 24 '13 at 15:29

You might have a look at fancontrol.
Configure it with pwmconfig. You have to do some trial and error to get a good balance between core temp and noise.
By default, the fan control is left in "automatic" mode, ie managed by the BIOS. (On my ACER desktop this means it runs at lowest speed whatever the temperature, hence stability issue...)

Edit
Googling around for "Dell 1555 fancontrol linux" gives you a bunch of wiki pages and forum threads. It seems that there can be 2 problems: CPU fan with kernel ~ca 2.6.32 (should not be relevant w/ ubuntu 12.10) and GPU fan with recent open source radeon driver. You could try fglrx, the proprietary AMD driver. I can't help you for that as I don't have ubuntu, but IIRC there is a simple men to get it installed.

share|improve this answer
    
This looks worth trying. Currently I am out station much so I cannot try for few days. –  Satya Prakash Feb 6 '13 at 16:56
    
Output: /usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed. :( –  Satya Prakash Feb 10 '13 at 16:26

There used to be a program, called dellfand but it's site has been off for a while and the project seems to be abandoned; although you can still find version 0.9 here, but you have to compile it. It solved reducing fan speed for me with a Latitude E6400 anno.

share|improve this answer
1  
Reduce fan speed --> CPU doesn't get cooled (enough) --> Paf. –  vonbrand Feb 11 '13 at 17:15
1  
Usually Dell is a bit paranoid on cooling, there IS a limit where you could safely raise the lower end temperature limit for fan speed. Of course, use it carefully. –  petermolnar Feb 11 '13 at 17:51
    
@petermolnar can you tell me more about it! How to raise lower end? example etc. –  Satya Prakash Feb 13 '13 at 13:00

This problem isn't as easy as changing a setting.

It is related to more that one thing probably.

From my experience, most problems of a "fan being loud" means that your CPU is running hot and your fan is trying to cool it, and said fan, has some kind of mechanical issue (breaking, broken, or about to be...).

This happens because your fan has been probably been working too hard for too long, took on some dust and now is failing. This is fairly common in notebook computers.

There are three things you should think about doing :

1. Clean the fan.

this option is a good place to start...

Shut off your computer and blow out the fan with some compressed air as best you can.

Better outsite if possible! Clear out all that junk in the fan.

2. Monitor your daemon processes and ram usage

run a quick top to see which processes are using a large amount of your CPU. if they seem out of the ordinary, try to resolve the issue.

also try free to see how much free memory you have. If you dont have much free ram, a lot of the data might be "swapped" in and out of your swap space using a lot of CPU overhead.

3. Dynamic frequency switching

Definitely look into some programs to switch your CPU frequency to a lower speed when you are doing simple tasks, email, writing docs etc.., and to a higher frequency when you want more power, for games or compiling.

you can also do this easily with a couple of small bash scripts similar to the command you are running in your post.

OH NOES!, Fan Still Super Loud!

If you tried everything and you still have problems, you will most likel

share|improve this answer
    
Swapping doesn't tax the CPU, quite to the contrary (no data at hand to frob --> CPU is idle). And be careful, free will tell you memory is almost full all the time, look at the line "+/- buffers/cache", that tells you if memory is really full. –  vonbrand Feb 11 '13 at 17:13
    
If fan is dirty etc then same problem will be visible on win 7 as well. Even I decided to use Linux and I kept Win7. –  Satya Prakash Feb 13 '13 at 12:58

You apparently have problem with overheating, about which some of the answers give some hints. Once the heat problem is solved, you might well find your fan still spinning too fast and causing noise.

As already suggested, use i8kutils. Many Dell users however will require a trick to disable the BIOS fan control. If you can set the fan speed with ì8kctl, but find that the new speed is fought back by something else, you need to apply this trick to disable the BIOS fan control.

Disable BIOS fan control

Something fighting back on the setted speed (reported by many users on Dell Latitude laptops) is caused by scheduled SMM sessions setting the fan speed back. Luckily there is a way to disable BIOS fan control by writing to SMM registers.

Warning: see the warning in top of smm.c. This method will write to SMM registers. However, I've seen no user reports on this causing trouble. Also, all reports on trying this have indicated success in disabling the BIOS fan control.

i8kutils includes the source of a program smm but the i8kutils package does not include the compiled binary. What we'll do is to download the source code of i8kutils, compile the program smm, and run it with an apropriate argument to disable BIOS fan control by writing to SMM registers.

Download packages needed for building:

$ sudo apt-get build-dep i8kutils

Download i8kutils source code, extract and enter directory (exact names depending on i8k version):

$ apt-get source i8kutils
$ tar xvf i8kutils_1.33.tar.gz
$ cd i8kutils-1.33/

Compile smm if on a 32-bit system:

$ make

(Above will execute gcc -g -O2 -Wall -I. -o smm smm.c.)

Compile smm if on a 64-bit system:

$ gcc -g -O2 -Wall -I. -o smm -m32 smm.c

Run smm with argument 30a3 to disable SMM fan control:

$ sudo ./smm 30a3

Now, BIOS fan control should be disabled. Try by setting speeds with i8kctl, listen for the fan and make sure the speed persists.

Note: This is a setting that will persist reboots and power-off's. BIOS fan control can be enabled again with $ sudo ./smm 31a3.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.