Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Update: I have created a new user via adduser and Virtualbox fonts are OK there. This does not solve my problem, however... I still don't know what is going on and I'd like my own user account to have the correct settings.

In my fresh install of Debian with Xfce, programs such as QtConfig, VLC and Virtualbox, which presumably use the Qt GUI framework, all have Greek fonts.

This is really annoying, and I'd like to change it to something understandable, preferably the system-wide font settings.

Here are some screenshots:

QtConfig: QtConfig Virtualbox: Virtualbox VLC: VLC

How can I solve this?

Additional info:

locale says:

LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

egrep '^[^#]' /etc/locale.gen says:

en_US.UTF-8 UTF-8
share|improve this question
    
Have you selected a greek locale/theme? Here it is described how you can reset all your kde settings. –  jofel Jan 31 '13 at 10:53
    
I'm using Xfce. –  akled Jan 31 '13 at 18:02
2  
Can you try to set the font manually as here described. –  jofel Feb 1 '13 at 10:58
1  
Try adding LC_ALL=en_US.UTF-8 and LANGUAGE=en_US.UTF-8 to your /etc/locale.conf file. If after rebooting that doesn't fix the issue, try running virtualbox from a terminal with (LANG=en_US.UTF-8 VirtualBox) (or whatever the name of the executable is) and see if that changes anything. But most likely a bug report is in order. –  Martín Canaval Feb 1 '13 at 15:06
1  
If so, please check your Qt settings on your original user. –  schaiba Feb 3 '13 at 13:27
show 10 more comments

4 Answers

up vote 1 down vote accepted

It's not a locale problem.

I don't know Greek but I can tell from your screenshot that it's perfectly normal English. It quite clearly says "Welcome to VirtualBox", there's a button that says "New", the one next to it suspiciously looks like "Settings", there are several "the" and other English words. If it actually was Greek I'd expect it to look very different.

So it's not locale and it's not Greek but English.

I suppose you have installed or selected some Joke font on your system which displays ABC characters in Greek equivalents. Unfortunately I am not fluent enough in Qt configuration nor do I know which font that could be to point you directly to the solution.

Maybe it will help you anyway.

share|improve this answer
    
Yeah, we have already figured that out, but +1 for that package information. –  akled Feb 5 '13 at 17:02
    
You could go for a divide and conquer approach. See if you can reproduce the issue if you copy all config files (the hidden files and dirs) to another user account. If that reproduces the issue, delete one half of the files. If the issue goes away, delete the other half. Rinse and repeat until you're left with the culprit file. It's annoying and a last resort if you have no other pointers. –  frostschutz Feb 5 '13 at 19:31
add comment

Try adding the following to your /etc/default/locale file, maybe also on /etc/environment.

LC_ALL=en_US.UTF-8
LANGUAGE=en_US.UTF-8

More adequately add the following to /etc/profile

: ${LANG:=en_US.UTF-8}; export LANG
: ${LC_ALL:=en_US.UTF-8}; export LC_ALL

If after rebooting that doesn't fix the issue, try running virtualbox from a terminal like this

(export LANG=en_US.UTF-8; export LC_ALL=en_US.UTF-8; VirtualBox)

or whatever the name of the executable is, and see if that changes anything. I read somewhere that qt 4.7 had locales issues, fixed on the 4.8 version.

Edit, as Chris Brown mentioned on the comments, Setting the LC_ALL variable globally is not a graceful solution. It's more intended as a temporary workaround in case the problem is the bug on the 4.7 version. This change should be undone if that is not the problem or if it's fixed after upgrading to qt 4.8.

share|improve this answer
    
Sadly, none of the things you had suggested have worked... –  akled Feb 2 '13 at 14:21
1  
Try creating a test user and see if issues persist. –  schaiba Feb 2 '13 at 14:53
    
Setting LC_ALL as a global override is not a graceful way to handle this situation. –  Chris Down Feb 2 '13 at 15:07
    
@ChrisDown, well, it doesn't work either way. –  akled Feb 2 '13 at 15:12
    
@schaiba - how does one upgrade Qt? AFAIK it's a C++ library, so I doubt it has a runtime (shared libraries?). –  akled Feb 2 '13 at 15:13
add comment

Try backing up or clearing your ~/.config/Trolltech.conf

share|improve this answer
    
Backed it up and then I rm'd it. The fonts were still undesired, but the file appeared again... –  akled Feb 3 '13 at 14:47
    
Yep, confirming now: diff of the test user's Trolltech.conf and mine is none. –  akled Feb 3 '13 at 14:54
    
Please paste the output of 'env | grep -i lang' –  schaiba Feb 3 '13 at 14:56
    
Additional possibilities: ~/.config/Trolltech/, ~/.config/fontconfig/, ~/.kde4/ The font is called "Standard Symbols L", maybe grepping $HOME helps. –  t-8ch Feb 3 '13 at 15:17
    
@schaiba:LANG=en_US.UTF-8 (newline) LANGUAGE=en_US.UTF-8. –  akled Feb 3 '13 at 21:54
show 2 more comments

as root:

dpkg-reconfigure locales
share|improve this answer
    
Sadly that didn't work. –  akled Feb 4 '13 at 16:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.