Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have sort of this in my .netrc:

machine ftp.mydomain.com
        login mylogin 
        password mypassword

and while I can succesfully connect with ftp:

ftp ftp.mydomain.com

and passing credentials to ncftp:

ncftp -umylogin -pmypassword ftp.mydomain.com

I get this using only ncftp ftp.mydomain.com

NcFTP 3.2.4 (May 16, 2010) by Mike Gleason (http://www.NcFTP.com/contact/).
Connecting to xxx.xxx.0.140...                                                    
ProFTPD 1.3.1 Server (Debian) [::ffff:xxx.xxx.0.140]
Login incorrect.                                                                
Sleeping 20 seconds... 

Any advice welcome...

share|improve this question
up vote 3 down vote accepted

man ncftp states, that ncftp do not use .netrc file for storing preferences. See FILES section for details. Instead it use $HOME/.ncftp/ directory. Just connect to your server and use bookmark command for creating a record in $HOME/.ncftp/bookmarks file

share|improve this answer
I relied on this doc I found online but it was wrong... However the bookmarks facility forces using at least once in interactive mode, not always what you want... Thanks – neurino Jan 30 '13 at 17:55
This man is very old, I guess. I could not find any mentions about netrc in change log – dchirikov Jan 30 '13 at 18:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.