Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using openSUSE 11.3 with "latest updates". I have installed vimprobable and uzbl.

Whenever I start one of those two browsers, I get the error message:

icedteanp plugin error: Failed to run etc/alternatives/../../bin/java.
For more detail rerun "firefox -g" in a terminal window.


After some time (about 1 minute), the message disappears by itself (or when I click the "close" button). The browser(s) continue loading and again, this error appears on specific sites.

What can I do to fix this problem?

share|improve this question
1  
So what happens if you start a terminal window and run firefox -g? Also, please post the output of ls -l /etc/alternatives/java /usr/bin/java. –  Gilles Jan 23 '11 at 11:23

2 Answers 2

I had this problem and resolved it by going into YaST Software Manager and deleting the OpenJDK version of Java.

share|improve this answer
    
Deleting or uninstalling? –  vgoff Nov 17 '12 at 0:15

Your java alternative is not configured properly, the webbrowser cannot find the binary.

Update your alternatives:

update-alternatives --config java

This should output only one (with a path) or multiple alternatives to choose from. If only one, check if the path exists, else select your alternative.

Try again opening a page containing java elements.

Still the same error?

First, find out what provides java:

rpm -q --whatprovides java

If this returns nothing, you have to install java first.
Otherwise, check where exactly the binary lies:

rpm -ql <package-from-above> | egrep '/bin/java$'

This should show the java binary.

Now update your alternatives to refer to that binary:

update-alternatives --set java <path-from-above>
share|improve this answer
    
thank you wag! The problem is totally gone after I installed java-src, dev –  aksr Jan 24 '11 at 15:33
    
Installing new software can also trigger the update-alternatives program like described above. –  wag Jan 24 '11 at 17:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.