Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed Debian 6.0, encrypted / and now I'm trying to boot. When GRUB comes up, I select Debian, it loads the initrd and asks for the root password, however I can't enter anything, because the system doesn't recognize my keyboard. It is a standard USB keyboard. What can I do to get my keyboard working?

share|improve this question
I'm assuming that you are referring to the root partition encryption passphrase, rather than the root password (which is something else and comes much later, if at all). While you are entering the passphrase (and this is normal for password/passphrase entry at *nix consoles), nothing is echoed back to you. Try simply hitting Enter once; that will tell you if input is recognized at all. I also tend to hit Num Lock once or twice, as a keyboard diagnostic. Debian 6.0 should support USB HID keyboards out of the box, and if it works in GRUB, at least keyboard-computer communications works properly. – Michael Kjörling Jan 30 '13 at 14:53
Yes, the Keyboard is working, but not while unlocking the "/" partition. I plugged in a old keyboard via the PS/2-Hub and it worked. Anyway, i´ll try the solution from Endre Szabo below. Thank you! – TobiasPC Jan 30 '13 at 15:08
Is the keyboard not responding at all at that point, or does what you type simply not show up on the screen? That's what you'd test by hitting Enter. – Michael Kjörling Jan 30 '13 at 15:18
it was not responing at all. works now, thanks! – TobiasPC Jan 30 '13 at 15:28
But what about the overwhelmingly vast majority of users who don't have a PS/2 keyboard? Are they shit out of luck? Or does one have to re-install the debian distro from scratch with partition encryption disabled? – Benjamin R May 23 '15 at 20:43
up vote 2 down vote accepted

Either add the following into the /etc/initramfs-tools/modules:


or change the module policy to most in /etc/initramfs-tools/initramfs.conf:


After this, repack the initramfs with the command:

update-initramfs -u

share|improve this answer
You need to run update-initramfs -u at the end to apply the changes. See this wiki entry. But as Michael Kjörling commented, this change is probably not be longer necessary in Debian 6.0. – jofel Jan 30 '13 at 15:03
Thanks, this worked perfect! – TobiasPC Jan 30 '13 at 15:28

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.