Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.
Listening IPv4://0.0.0.0:5900

After a bit of searching I found this in an error log somewhere. I appreciate the vagueness of this but how do I configure the ip vino should be listening on?

also I cannot find the location of the vino binary either.

It's not in /usr/bin/ where the client vinagre is.

edit: once a session is created locally on the machine in question vino does start listening on 5900, which i guess is the whole point of remote desktop as opposed to remote x window tunnelling (ie you want someone to log in remotely to an existing session). But I still cannot create a remote desktop session using vino from a remote client (I use remmina on the client machine) over the lan.

Client-wise Remmina just reports

[VNC]ConnectClientToTcpAddr6: connect
[VNC]ConnectToTcpAddr: connect
[VNC]Unable to connect to VNC server

and I can create a remote x window ssh tunnel so there is no problem connecting to the box.

share|improve this question
    
Did you open the port in the firewall? –  Michael Hampton Jan 29 '13 at 23:30

1 Answer 1

The address on which a TCP server is listening is the address of the network interface on the local machine that packets must arrive through. This is a primitive form of access control. When a server is listening on 0.0.0.0, it means that it accepts connections through every interface. A common restriction is to listen only on 127.0.0.1, which means that only local processes can connect to that server. Here, the server isn't restricted.

If you want to restrict Vino to a specific interface, modify its configuration and change the /desktop/gnome/remote-access/network-interface setting.


If you can't connect from a remote client, something else is preventing you. It could be a firewall, a client misconfiguration, or a server bug. To rule out a server bug, make sure that you can connect locally. Check your firewall configuration on the server machine:

iptables -nvL

(must be executed as root) and look for something that would deny incoming connections on port 5900 (post the output of that command if you need help interpreting the output).

To check whether something between the client and the server is blocking connections, run tcptraceroute server-host-name 5900 on the client machine.


You do need to start the Vino server before you can connect to it with a client. Vino is the back-end for the shared session, and you can connect to an existing back-end with one or more front-ends.

share|improve this answer
    
thanks for the descriptive explanation. I can create a 'remote desktop' on the machine by logging in over remote X window and running vinagre client on it locally. So it's doesn't seem to be a vino issue. Here is my firewall config pastebin.com/hxBmYHTV I'm not really sure what that means. –  user1561108 Jan 30 '13 at 0:29
    
@user1561108 If I read correctly, incoming connections on port 5900 are blocked. You can either enable them, or (more secure) forward the VNC connection over SSH (ssh -L 5900:server-host-name:5900 …, then tell Remmina to connect to port 5900 on the client machine). –  Gilles Jan 30 '13 at 0:34
    
tried ssh -L 5900:server-host-name:5900 … but came back with ssh: Could not resolve hostname ...: Name or service not known. I realise I'm probably being dense here but even after man ssh I'm not sure what I should be replacing ... with if anything –  user1561108 Jan 30 '13 at 1:09
    
@user1561108 Replace server-host-name by the name of the machine that's running Vino. –  Gilles Jan 30 '13 at 1:13
    
yes did that but got the above error –  user1561108 Jan 30 '13 at 1:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.