Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I following a guide to have my tablet (Samsung ativ 700t running ubuntu 12.10 Gnome3) invert the screen 180 on login

I place a script file in /etc/X11/Session.d/45custom-script.

Contents of file: (going by memory)

  # I cannot remember if I had #!/bin/bash here at first but I'm betting no
  xrandr -o half
  xsetwacom set-prop 9 rotate 2
  xsetwacom set-prop 9 area 100 200 25000 14000 # numbers approximated   

On the next boot this rotated the monitor correctly but not the stylus input (device 9).

I then delete the xrandr line to just test the xsetwacom but on the next boot it was still flipped (login screen was normal).

Then I did a bunch of things to attempt to fix it

  • changed the xrandr to xrandr -o none
  • changed the file name to 95custom-script and invert-screen removed the file completely
  • made sure to delete the 'filename~' files that gedit created
  • removed the xsetwacom lines
  • removed and added #!/bin/bash and #!/bin/sh to the top

My only theory is that the command was copied somewhere else and will not change again.

share|improve this question
    
Did you put it in ~/.xinitrc or something similar? –  John Siu Jan 30 '13 at 1:09
    
No, was i suppose to? –  Will McG Jan 30 '13 at 14:28
    
I mean if you put it there before, then you may have to remove them, otherwise those setting will be applied every time you r login. –  John Siu Jan 30 '13 at 15:16
    
I only messed with the Session.d folder. My entire process of what I tried is in the question. I did nothing outside of what is mentioned above. If I am suppose to do something with the ~/.xinitrc could you explain, I have no idea what to do. –  Will McG Jan 31 '13 at 19:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.