Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am using some GTK+ applications in Mac OS X Snow Leopard. My MacBook is configured for using the Brazilian layout, which allows it to enter diacritics as dead keys (so I can write á typing ' and then a, for example). However, it does not work in some GTK+ applications - in this case, Gedit and GnuCash. In other ones, such as Inkscape and Dia, I can enter diacritics as dead keys. It is valid to note that Dia and Inkscape runs through X11 but Gedit and GnuCash (at least my versions) do not.

Does anybody have such problem? Has someone solved it? How could I configure the keyboard layout for GTK+? Do I do it in some ~/.gconf* or ~/.gnome file?

Thanks in advance?

share|improve this question
    
In Gedit and Gnucash, when you type ' then a, what happens (do you get 'a, a, nothing, something else)? –  Gilles Jan 22 '11 at 20:12
    
I got the first option: 'a –  brandizzi Jan 31 '11 at 16:39
    
Right click on a text field and go to Input Methods. What is selected for working vs. non-working apps? Usually System is the default. –  penguin359 Apr 21 '11 at 0:26
    
Hi, penguin359! Both working and non-working apps use the "System" input method. In Inkscape, it is presented as "System (Simple)". Also, I've tried all other methods available in the popup menu and none worked. –  brandizzi Apr 25 '11 at 18:14

1 Answer 1

You say Gedit is not usng X11; which version of gtk-quartz does it uses?

Maybe it is the osX specific layer used that is not properly supported by gtk? see also: https://bugzilla.gnome.org/show_bug.cgi?id=617583

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.