Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I added this entry to menu.xml:

<item label="Rosetta">
  <action name="Execute">
    <command>
       wine ~/.wine/drive_c/Program\ Files/Rosetta\ Stone/Rosetta\ Stone\ Version\ 3/RosettaStoneVersion3.exe
    <command>
</action>
</item>

But when I click this, Rosetta opens with error 2123. This error, I think, is associated with bad shortcuts. I'm not sure.

However, when I go to the folder and click on the exe file, it runs correctly.

I tried prepending the command with 'sudo'. Didn't help.

The command must be incorrect but I don't know why.

What am I doing wrong?

Just to be clear:
When I click the Rosetta Stone icon, the program runs. When I navigate to the folder in terminal and use "wine RosettaStoneVersion3.exe", it also runs. But when I run "wine ~/.wine/drive_c/Program\ Files/Rosetta\ Stone/Rosetta\ Stone\ Version\ 3/RosettaStoneVersion3.exe", it opens with "error 2123".

I can't figure out why this would be.

share|improve this question
    
According to this it's a permission conflict. How did you install the app? –  rahmu Jan 29 '13 at 18:12
    
Try doing cd to directory with .exe before running it with wine –  gelraen Jan 29 '13 at 18:47
    
@gelraen I added some details to my question. If I cd there, it runs fine. But when I use a path, I get error 2123. I can't understand this. –  Korgan Rivera Jan 29 '13 at 19:19
2  
Well, it seems pretty obvious to me that this crap just unable start from anywhere but it's own directory. So just use something like cd ... && wine crap.exe as a command. Or sh -c 'cd ... && exec wine crap.exe' if that doesn't work. –  gelraen Jan 30 '13 at 17:27
    
well, it's pretty usual for windows software to run only from some specific directory. Installer-created shortcuts usually have working directory specified, so that's not a problem in windows –  gelraen Jan 31 '13 at 10:54

3 Answers 3

At a glance, it appears to be the path you are giving wine (disclaimer: I have no clue at all about the way that Openbox parses menu.xml).

You currently have:

wine ~/.wine/drive_c/Program\ Files/Rosetta\ Stone/Rosetta\ Stone\ Version\    3/RosettaStoneVersion3.exe

Note the three spaces between "Version" and "3". If there are truly three spaces, you want:

wine ~/.wine/drive_c/Program\ Files/Rosetta\ Stone/Rosetta\ Stone\ Version\ \ \ 3/RosettaStoneVersion3.exe

If there is only one space, remove the trailing spaces.

share|improve this answer
    
I just typed it incorrectly in the question. :) –  Korgan Rivera Jan 29 '13 at 17:55
up vote 0 down vote accepted

@gelraen Your answer gave me what I needed. The solution turned out to be sh -c 'cd ... && exec wine Rosetta.exe' Pretty frustrating bug. Thanks for you help! :) And I agree. Rosetta sucks. I'm setting this up for a friend.

share|improve this answer

Well this was toiling my brain for some time. I followed this guide initially. Rosetta Stone wouldn't launch. I use Lubuntu 14.10 x64. Here was my solution.

Part 1:

navigate to ~/.local/share/applications

right click created file and click Properties -> Desktop Entry

Part 2:

for the command put:

sh -c 'cd "~/.wine/drive_c/<directory with Rosetta Stone>" && exec wine "YourRosetta.exe"'

Seems there was a problem with the format before.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.