Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a nice tmux status line, but I don't like how the bash/commands run flush along it...that is, if the screen is full, i'm typing things right above the status line.

I'd like a one line break above it, so that what i'm typing ever "touches" the status line...is there any way to do this?

Example:

Let's say I have a very small terminal window that is two lines long

bash>$ (cursor)
1: bash*  2: bash-  3: vim-

How would I get a blank line to separate the status bar from the prompt, like:

bash>$ (cursor)

1: bash*  2: bash-  3: vim-
share|improve this question
    
Could you provide a screen shot? –  Sardathrion Jan 29 '13 at 8:21
1  
@Sardathrion I added a visual indication of what I am talking about, does that help? :) –  Justin L. Jan 31 '13 at 19:09
    
Yes, it does. Thank you. –  Sardathrion Feb 1 '13 at 7:38
1  
Powerline has some tmux bindings that you might find helpful. –  Sardathrion Feb 1 '13 at 7:41
    
select-layout should help, I think –  sendmoreinfo Feb 23 '13 at 7:43

1 Answer 1

If you don't mind typing directly above the pane border (which you have to do anyway for any panel that doesn't touch the status line), you can force tmux to use a smaller window:

set force-height <single_window_height - 1>

However this only is a per-window setting and acts as maximum height limit hence it won't do what you want when you change your containing terminal dimesions.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.