Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I need an idiots guide to installing Xen Hypervisor on CentOS 5.9

We attempted to install it on 6.3 before, but completely failed, so we reverted to 5.9 to see if we had more luck. We had issues trying to find the right kernel download etc and RPM's weren't working correctly, and it was just a mess in general.

So I was wondering if anybody knew of a great step by step guide to installing Xen Hypervisor on CentOS 5.9 for idiots, that is still 100% working?

share|improve this question
1  
Sorry, can't answer your question, but want to make a comment: Red Hat/CentOS are going the KVM way and Xen is all but deprecated on those systems. Might it make more sense to follow that lead and use KVM? –  Dennis Kaarsemaker Jan 28 '13 at 23:35
    
From what I can see it looks incredibly complicated to do anything with it. I'm setting up a small hosting busines, so I need ease of use, and such like, and to me, KVM just doesn't seem like the answer. Also it looks like it's more aimed at people that want to use it simply because they want more than one OS on their system. I was it to replicate a template and place all the files it needs to run inside it, and that is it. But we're also hosting minecraft servers, we had issues with resources when it came to minecraft with OpenVZ previously, this is why we wanted to swap over to XEN. –  Conner Stephen McCabe Jan 30 '13 at 15:49
    
See the answer from jordanm. Start at Chapter 6. –  Nils Jun 20 '13 at 20:33

1 Answer 1

The official RHEL 5 Virtualization Guide contains everything you need to know for setting up Xen in CentOS 5.9. As Dennis has mentioned in the comments, Red Hat is making a push for KVM, so the RHEL 6 version only contains documentation for setting up KVM.

share|improve this answer
    
But RHEL6 still works out of the Box as PV DomU. No special kernel needed there. Sad that they do not support it as Dom0. –  Nils Jun 20 '13 at 20:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.