Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've spent 2 hours on this and still can't figure this out. It's driving me insane. Please save my sanity.

When I press mute, the pnmixer control in the top right shows that I've pressed mute, but the sound is not muted. A graphic also appears on my screen with a volume bar to show that the volume has been muted.

When I press mute again, the pnmixer control shows that I have pressed the key, and three graphics appear on my screen in a row to show that I've pressed it. This doesn't make sense. No change in sound.

With the volume up and volume down keys, the graphic changes accordingly but again no change in sound.

I've tried editing rf.xml with the following:

<!-- Keybindings for volume keys -->
   <keybind key="XF86AudioRaiseVolume">
  <action name="Execute">
    <execute>amixer set -q Master,0 5%+</execute>
  </action>
</keybind> 
<keybind key="XF86AudioLowerVolume">
  <action name="Execute">
    <execute>amixer set -q Master,0 5%-</execute>
  </action>
</keybind>
<keybind key="XFAudioMute">
  <action name="Execute">
    <execute>amixer set -q Master,0 toggle</execute>
  </action>
</keybind>

I used xev to get the names of the key bindings.

After reconfiguring or restarting openbox, or restarting my computer, this change in the script had no effect at all.

Btw, uname -a gives me: Linux KGBXCrunch 3.2.0-4-amd64 #1 SMP Debian 3.2.35-2 x86_64 GNU/Linux

share|improve this question
1  
Did you try running the commands independently to see if they work? –  schaiba Jan 31 '13 at 21:19
    
One thing I noticed is that it should be mixer -q set Master. So the ` ,0 ` looks wired. Second shouldn't XFAudioMute be XF86AudioMute? –  Raphael Ahrens Nov 28 '13 at 19:15

2 Answers 2

My stab at this: it sounds like the programs are registering the correct key commands (as evidenced by the visual cues.) Are you positive that your sound card's hardware is actually being managed by the mixer?

This thread has some great general audio issue troubleshooting tips:

http://crunchbang.org/forums/viewtopic.php?id=4432

But my guess is that the audio management interface isn't actually in control of your systems audio hardware (at the moment.) Sussing that out might not be all that simple. If I were in your shoes, I would try a live CD boot of Ubuntu (also based Debian based distribution) and see if their default audio management settings work. If they do, then you can safely rule out actual hardware malfunction, and try and get a clue as to what packages were actually being used, in what way, and apply them to your #! install.

share|improve this answer

I had an HP DV4000 that was displaying the same symptoms as what you are describing- Volume control buttons appear to work (popup in the upper right), but they don't actually control the sliders in the GUI mixer. Stephan's idea that the volume control system was not in control of the hardware was correct. If you right-click on the sound icon in the upper right next to the clock (in default OpenBox), and click Preferences, it opens a dialogue that controls the settings for the volume control icon, which is the part that receives the signals from the keyboard volume control. In the tab Device, there is a drop-down menu called "Card:". Use this menu to select which audio card you want to control with the volume buttons. For the channel menu, you should select something like "Master" or "PCM" that will control the entire audio card (rather than "bass" or "treble"). Press OK. I got a "mixer detach error: no such file or directory", but I think that is an unrelated issue. The volume buttons should now work to set the sliders in the mixer. You may be able to set the card option back to "default".

So far, the only issue that I have encountered is that I can only control my internal audio card, even if I explicitly set it to the USB card, but that may be a different problem.

As for the three graphics for the volume control, you may have multiple instances of pulseaudio or alsamixer running. Does reboot solve it? If it doesn't, try commenting the keybindings that you inserted into rc.conf ( at the end of the block) and restart to see if that makes a difference. It may be showing three because it received the command three times. If commenting out the keybinding breaks the volume control ability (no more onscreen graphics), uncomment it and reboot to revert.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.