Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.
mkdir ~/mnt/2letter
echo PASSWORD | sshfs -o password_stdin www-data@localhost:/var/www/sites/2letter ~/mnt/2letter -o sshfs_sync,cache=no,password_stdin

After this:

$ ls -ld ~/mnt/2letter/
drwxr-xr-x 1 www-data www-data 4096 Jan 28 21:29 /home/porton/mnt/2letter/

I need to access /home/porton/mnt/2letter/ under my UID (porton) not as www-data, because I am not allowed by file system permissions to modify www-data owner files, but need to edit them.

Moreover it seems to have been working with the correct UID with older versions of Linux. Why doesn't it work now?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Try chucking in the two following options

-o idmap=user,uid=<YOUR UID>
share|improve this answer
    
Yes, it works, I need also to specify gid=XXX, but why does it works only with numeric IDs –  porton Jan 28 '13 at 21:18
1  
You will have to ask the author(s) of sshfs that question :) –  tink Jan 28 '13 at 21:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.