Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I don't have AES-NI available on my Dell Vostro 3360 laptop. Why? Does this machine not support it?

My /proc/cpuinfo:

processor   : 0
vendor_id   : GenuineIntel
cpu family  : 6
model       : 58
model name  : Intel(R) Core(TM) i5-3317U CPU @ 1.70GHz
stepping    : 9
microcode   : 0x15
cpu MHz     : 782.000
cache size  : 3072 KB
physical id : 0
siblings    : 4
core id     : 0
cpu cores   : 2
apicid      : 0
initial apicid  : 0
fpu     : yes
fpu_exception   : yes
cpuid level : 13
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer xsave avx f16c rdrand lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms
bogomips    : 3392.17
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:
share|improve this question
1  
software.intel.com/en-us/forums/topic/287887 makes it sound like this is a BIOS bug... –  derobert Jan 28 '13 at 21:07

3 Answers 3

Check against this list: http://ark.intel.com/search/advanced/?s=t&AESTech=true. It also might be an option in your BIOS, although I doubt it.

share|improve this answer
1  
I checked. Processor should have aes-ni according to this website. In bios I have no options like that. –  Alojzy Bomba Jan 28 '13 at 17:04
    
OK, so your CPU supports AES-NI. Check your kernel config for a line like CONFIG_CRYPTO_AES_NI_INTEL . It should be compiled in as a module usually. –  schaiba Jan 28 '13 at 18:14
    
Yes, I have such module but without aes among cpu flags I can not load it: modprobe aesni-intel ERROR: could not insert 'aesni_intel': No such device –  Alojzy Bomba Jan 28 '13 at 18:29
1  
You're not alone - Google finds several hits on Dell Vostro 3360 not supporting AES-NI. Could be it has a different CPU or just the BIOS not supporting it somehow. –  frostschutz Jan 28 '13 at 22:07
1  
If you are right, and I start to share your impression, it means that Dell is shit company. Look at that dell.com/support/drivers/us/en/19/… After few month the product has been released Dell decided to support all function given by Intel. –  Alojzy Bomba Jan 29 '13 at 0:48

Many companies are not enabling AES feature in laptops. For my Asus I found solution here: http://forum.notebookreview.com/windows-os-software/582628-aes-ni-support-truecrypt-sandy-bridge-problem-15.html#post8002488

I followed that few steps and successfully modified my BIOS. Maybe it will help you too.

share|improve this answer

No need to check on intel's site,

Just see if aes is one of your CPU flags by grep aes /proc/cpuinfo

(Works for me: i5 2450m)

If you got a match, it's supported.

share|improve this answer
    
for its processor the information on intel website says it's supported, but there is no such flag on /proc/cpuinfo. I think this difference is the reason he asked the question in the first place –  pqnet Aug 31 at 21:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.