Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have got a Solaris 10 on a VMware virtual machine in Windows. This is what I did:

1) Installed PuTTY.

2) Checked whether ssh is running or or not in my Solaris desktop as below:

    bash-3.00# ps -ef | grep sshd
    root  2001  2000   0 01:21:37 ?           0:00 /usr/lib/ssh/sshd
    root   602     1   0 23:28:23 ?           0:00 /usr/lib/ssh/sshd
    root  2000   602   0 01:21:37 ?           0:00 /usr/lib/ssh/sshd

3) Checked IP of my Solaris 10 VM:

bash-3.00# ifconfig -a
lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
        inet 127.0.0.1 netmask ff000000
e1000g0: flags=1004843<UP,BROADCAST,RUNNING,MULTICAST,DHCP,IPv4> mtu 1500 index 2
        inet 192.168.79.128 netmask ffffff00 broadcast 192.168.79.255
        ether 0:c:29:b6:1f:ec
lo0: flags=2002000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv6,VIRTUAL> mtu 8252 index 1
        inet6 ::1/128
e1000g0: flags=2004841<UP,RUNNING,MULTICAST,DHCP,IPv6> mtu 1500 index 2
        inet6 fe80::20c:29ff:feb6:1fec/10
        ether 0:c:29:b6:1f:ec

I am trying to connect using PuTTY with IP 192.168.79.128 on port 22 but this is what I am getting:

login as: root
Using keyboard-interactive authentication.
Password:
Access denied
Using keyboard-interactive authentication.
Password:

What am I missing?

share|improve this question

3 Answers 3

up vote 5 down vote accepted

Don't login as root over ssh; rather, create an user for logging in and then become root.

But editing /etc/ssh/sshd_config and adding the line PermitRootLogin yes (or changing if it's already set to No) should do it.

share|improve this answer

Remote root login is disabled by default. You should create another user to log in.

useradd -m -d /export/home/username username

And set a password

passwd username

If you do decide to allow remote root login, you need to edit the ssh configuration file to allow root login. First set this in /etc/ssh/sshd_config

Change the line that reads

PermitRootLogin yes

to read

PermitRootLogin yes

Then save the file and re-start the SSH daemon with

svcadm restart ssh
share|improve this answer

You need to allow PermitRootLogin in /etc/ssh/sshd_config:

PermitRootLogin yes

Another solution (preferable) is to add another user account with useradd user and set its password using passwd.

And after llogging as a regular user use su - to become a root

share|improve this answer
3  
Direct root login over the network isn't available by default for a reason... –  vonbrand Jan 27 '13 at 2:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.