Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have managed to install OpenBSD 5.2 on my DEC VaxStation 4000 Model 90 but to my surprise have not found a binary for Emacs (any version) for the VAX architecture. As best as I can tell I do not see it in the ports collection either.

Has anybody succeeded in installing any version of Emacs (or for that matter Zile) on the VAX architecture? Note that the VAX architecture distribution of OpenBSD uses a modified version of GCC 2.9.5 as it's compiler.

share|improve this question
1  
There is an emacs port. BSD/Vax is explicitly marked as supported in the MACHINES file on Emacs 23, but not mentioned either way on Emacs 24. –  Gilles Jan 26 '13 at 22:42
1  
I did compile emacs in my SunOS days, and it worked fine. It was an involved process, and you'd better have all your ducks lined up before starting, because there was no sane way to restart a failed build attempt. It did take quite some time, get an extra pack of patience. –  vonbrand Jan 27 '13 at 2:57
add comment

2 Answers 2

I haven't had the honour of playing with a VAX, but OpenBSD 5.2 has mg, a mini emacs clone. So if you can't compile emacs, mg should do. :)

share|improve this answer
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. –  Shadur Jan 26 '13 at 16:40
5  
I didn't critique, nor requested clarification. My answer was "you have mg as an emacs clone included in the base system". –  schaiba Jan 26 '13 at 17:07
2  
@Shadur His answer was helpful. I just confirmed that I do have mg installed already on the VAX install of OpenBSD. I was aware of and have used Zile in the past but was not aware of mg. I can now continue to avoid using vi! I will continue to try to install Emacs but now have an Emacs like editor at my disposal until I succeed. –  haziz Jan 26 '13 at 18:05
    
Another thing: by default, Emacs 24 is dependant on xz, which won't compile on VAX. This is confirmed by the package listing for VAX : ftp.aso.ee/pub/OpenBSD/5.2/packages/vax. –  schaiba Jan 27 '13 at 16:03
add comment

Install OpenBSD in a VAX emulator in your fastest machine. Download the ports repo from the CVS and compile some version of emacs. Share the directory with the packages compiled using NFS and install the wanted packages.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.