Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

If I don't have NetworkManager installed on Debian, I edit "/etc/network/interfaces" and then run ifup eth0. I see that things are different in Fedora 14 (the directory and the command aren't available). How do I do it?

share|improve this question
    
welcome to the world of learning another distro, and what the real differences are. :P p.s. you don't have to, but I leave questions unanswered for ~24 hours, it gives people a chance to review and upvote things, as peopled tend to look at answered things less I've found. –  xenoterracide Jan 21 '11 at 18:17
    
@xeno I get it. Well... in this case the solution worked immediately. Not doubts :) –  Tshepang Jan 21 '11 at 18:20
    
often they do, I just do it so everyone has a chance to earn points I don't think this Q&A would have gotten the upvotes it did had I accepted the answer the 5 minutes after I was told the 1 wrong character I did. but as I've said, you can do this however you want, unlike accepting your own answer there's no limits on when you have to do a regular answer. It also gives people a chance to write even better answers. –  xenoterracide Jan 21 '11 at 18:27
    
@xeno BTW I never hesitate to change Accepted answer whenever a nicer one pitches. Also, luckily Gilles doesn't care whether there already is an accepted answer or not. –  Tshepang Jan 21 '11 at 18:30
    
right... I just started doing it because it seems to keep more people (maybe not @gilles) interested for longer. about 1 day is the max though. –  xenoterracide Jan 21 '11 at 18:32
add comment

1 Answer

You can continue to use the 'network' service. Just run

sudo /sbin/chkconfig network on

and

sudo /sbin/service network start

and it will start the interfaces that are set up in /etc/sysconfig/network-scripts/ifcfg-*. You might want to check the settings in those files to make sure that the interface you want to start automatically on boot is set "ONBOOT=yes". For an interface to edit those files, you can use 'system-config-network' which is part of the system-config-network package (if not already installed).

share|improve this answer
1  
This is out of date these days. Ever since systemd it's sudo /usr/bin/systemctl enable network.service and sudo /usr/bin/systemctl start network.service. –  Omnifarious Aug 27 '12 at 5:28
    
Yes, in later versions of Fedora, that's correct. This was posted in January of 2011, about Fedora 14, which didn't include systemd. –  jsbillings Aug 27 '12 at 16:29
2  
Yep, I realize that. My comment was more a matter of "This information is old and it's different now." than "Hah, you're wrong, it's this way!". I found it while searching for this information myself, and I just wanted to make sure it stayed up-to-date for future readers. –  Omnifarious Aug 30 '12 at 1:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.