Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've just installed #! and I'm loving the customizable Openbox DE.

However, when I press the power button on my laptop, the system doesn't react.

For example, when I was using Debian & Gnome, and when I pressed the said button, Gnome displayed a dialog box asking me whether I want to shutdown etc.

The mentioned dialog box also appears when I go to menu->exit in Openbox.

Question: How can I bind the shutdown button to Openbox->exit?

Some info:

xev + shutdown button says:

KeymapNotify event, serial 46, synthetic NO, window 0x0,
    keys:  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
share|improve this question

2 Answers 2

up vote 0 down vote accepted

I have installed Xfce and it works now.

Go to Settings > Power Manager and set those options to "Ask" or whatever you prefer.

share|improve this answer

Have you tried the oblogout application? https://launchpad.net/oblogout

share|improve this answer
    
I resolved the dependencies but there are still errors in the program... I'd prefer something that works natively, not a third-party program. –  jco Jan 26 '13 at 16:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.