Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

OpenSUSE 12

LAN driver is up and running:

me@here:~> /sbin/ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1A:4D:F9:93:F2  
          inet fe80::21a:4dff:fef9:93f2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metracic:1                                                                                                                        
          RX packets:406 errors:0 dropped:72 overruns:0 frame:0                                                                                                                     
          TX packets:64 errors:0 dropped:0 overruns:0 carrier:0                                                                                                                     
          collisions:0 txqueuelen:1000                                                                                                                                              
          RX bytes:33701 (32.9 Kb)  TX bytes:9039 (8.8 Kb)                                                                                                                          
          Interrupt:44 Base address:0x8000                                                                                                                                          

lo        Link encap:Local Loopback                                                                                                                                                 
          inet addr:127.0.0.1  Mask:255.0.0.0                                                                                                                                       
          inet6 addr: ::1/128 Scope:Host                                                                                                                                            
          UP LOOPBACK RUNNING  MTU:16436  Metric:1                                                                                                                                  
          RX packets:240 errors:0 dropped:0 overruns:0 frame:0                                                                                                                      
          TX packets:240 errors:0 dropped:0 overruns:0 carrier:0                                                                                                                    
          collisions:0 txqueuelen:0                                                                                                                                                 
          RX bytes:17863 (17.4 Kb)  TX bytes:17863 (17.4 Kb)

me@here:~> /sbin/arp
Address                  HWtype  HWaddress           Flags Mask            Iface  
78.90.162.1              ether   00:1b:fc:66:4e:86   C                     eth0  

However, I can't seem to ping the router:

me@here:~> ping -b 78.90.162.255  
WARNING: pinging broadcast address
PING 78.90.162.255 (78.90.162.255) 56(84) bytes of data.
^C
--- 78.90.162.255 ping statistics ---
10 packets transmitted, 0 received, 100% packet loss, time 8999m

Through the same cable, a WindowsXP machine connects just fine, outputting the following parameters:

IP address 95.111.106.82
subnet mask: 255.255.255.0
Gateway: 95.111.106.65
DNS Server: 95.111.106.65

What should I do from here on?

share|improve this question
5  
The interface is "up and running", but it does not have any IPv4 address, which probably means the IPv4 networking wasn't even set up properly. What are your routes? (Just show the output of route) –  njsg Jan 25 '13 at 13:30
    
How is networking set up? The IPv6 address is just locally configured. –  vonbrand Jan 25 '13 at 21:31
    
Were you able to successfully get connection to your router? –  Josh Blair Jan 29 '13 at 16:29

2 Answers 2

up vote 1 down vote accepted

I agree with @njsg that the adapter is not assigned an IPv4 address. I would suggest disabling IPv6 completely and then rebooting the machine. The easiest way to do this is to go through YaST. Go to YaST > Network > Network Settings and you should see an option on the 'Global Options' tab to disable IPv6. Then reboot and see if that fixes the issue.

share|improve this answer
    
What does OpenSUSE derive a correct IPv4 setting from disabling IPv6? –  Bananguin Jan 25 '13 at 14:46
    
It's a simple thing to attempt and it's something that has worked for me when working with OpenSUSE and had IPv4/6 issues. –  Josh Blair Jan 25 '13 at 14:51
    
It doesn't configure IPv4, that is all... –  vonbrand Jan 25 '13 at 21:31
    
Turned out the connection is through a switch and the provider sees an IP/MAC combination that is different than the one he remembers. –  Vorac Feb 8 '13 at 9:00

Why do you want to ping the broadcast address? Can you ping the gateway you mentioned (95.111.106.65) ? Any external addresses?

share|improve this answer
    
I fail to ping 95.111.106.65. External addresses at alphanumerical format e.g. www.google.com also fail. –  Vorac Jan 25 '13 at 13:28
    
This is more appropriate as a comment on the original question; it is not an answer. –  uther Jan 25 '13 at 13:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.