Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am running F14 on my laptop, and I use it either with or without an external screen.

[nbarraille@barraille ~]$ xrandr | grep " connected "
LVDS1 connected 1280x800+1280+0 (normal left inverted right x axis y axis) 304mm x 190mm
VGA1 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 338mm x 270mm

When the VGA screen is plugged in, everytime I reboot the system sets it up so that VGA1 is a clone of LVDS1 and I have to do a:

xrandr --output VGA1 --left-of LVDS1

How can I change it to be the default behavior?

Thanks!

share|improve this question

1 Answer 1

Assuming you're using Gnome, try using System->Preferences->Monitors. KDE has a similar tool in System Settings->Display.
I don't know if hot-plugging makes any difference, but this tool will save your settings so anytime you reboot it'll use the same settings as last time.

share|improve this answer
    
I am using KDE. I did try the System Settings>Display, changed it there and applyed "Set to Defaults" but it doesn't work and everytime I reboot, it resets to "Clone" –  nbarraille Jan 21 '11 at 16:21
    
I think the "Set to Defaults" option reverts any changes you've made. It doesn't create a new default. –  jonescb Jan 21 '11 at 16:23
    
In the menu Save as Default, you have two options: Save as Default and Reset. I assumed that Set as Default should set the current configuration as Default. –  nbarraille Jan 21 '11 at 16:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.