Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I use Debian Wheezy.

Yesterday I added a new HDD to the system and expanded the LVM using the system-config-lvm gui-tool.

I have a logical LVM group for root, /, and one for home, /home. I also installed updates.

Boot process: Boot process

Windows 7 boots fine

How can I fix it?

share|improve this question
    
The message on the middle of the screen is rather clear: a disk with that uuid could not be found. –  ott-- Jan 24 '13 at 21:31
add comment

3 Answers

It's not clear exactly what you did when you “expanded the LVM”. It seems that what you did required updating some values that Grub needs to locate the root filesystem: one of the hard disks has changed its identification.

While it is probably possible to boot your system by issuing the right commands at this prompt, this is pretty complex and difficult to explain without being in front of the machine. You'll have to locate the root device, mount it and run /init to switch to it.

I recommend booting from a rescue CD/USB. SystemRescueCD is a good choice. Activate and mount your system's root volume, then run the following commands in a terminal (with the root volume mounted on /target):

mount --rbind /dev /target/dev
mount --rbind /proc /target/proc
mount --rbind /sys /target/sys
chroot /target
update-grub

With your setup, I think this will result in a bootable system. If it doesn't, post the contents of /boot/grub/grub.cfg and /etc/fstab.

share|improve this answer
    
update-grub output pastebin.com/0FjsZyFw grub.cfg pastebin.com/ZvfVZZPE fstab pastebin.com/73YaJjsY –  corppneq Jan 25 '13 at 0:48
    
Can he run sudo blkid -c /dev/null using the System Rescue CD to see what the UUIDs of his devices are? Could his expansion changed the UUID of the partition? –  HeatfanJohn Jan 25 '13 at 1:38
    
The new hdd was missing in /boot/grub/device.map I used grub-mkdevicemap to generate a new one. Now I have a new error error: unknown LVM metadata header. pastebin.com/6ZGXSX0R –  corppneq Jan 25 '13 at 2:06
    
My system starts correctly now. But how can I get rid of this error? –  corppneq Jan 25 '13 at 2:30
add comment

Your error is not related to grub, but to the Debian initrd system. After grub load the initrd file system and the kernel, it run the kernel on a ramdisk with initrd. This initrd system include a series of command that should load you system.

One of the firsts step is to load all drivers, check for all hardware usable for booting, then looking for the device passed as ROOT parameter when grub started the kernel.

In your case, this ROOT device is not present, so you have a few options: one of them may be to extend the period the kernel wait in order to check for all sow devices. I don't think this is your case. So i assume you have some problem with your LVM configuration, and suggest to remove the new hard disk.

It is not clear if you expanded just the LVM group (adding a new phisical volume to the group) or if you also extended the LVM volume of root. In the first case, you may boot from a CD, reduce the group removing you new hard disk, and reboot.

If you extented your LVM root volume and resized that file system, you have to shrink the (unmounted) file system, then reduce the volume, then reduce the group and remove the new hard disk.

share|improve this answer
add comment

The kernel isn't finding the filesystem for /. You can use tune2fs(8) to set the UUID of your new / to what it is asking here.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.