Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm setting up an xmonad window manager and I came across following problem - when I try to configure xmobar and run it it shows:

xmobar: .xmobarrc: configuration file contains errors!
Usage: xmobar [OPTION...] [FILE]
Options:
  -h, -?        --help               This help
  -V            --version            Show version information
  -f font name  --font=font name     The font name
  -B bg color   --bgcolor=bg color   The background color. Default black
  -F fg color   --fgcolor=fg color   The foreground color. Default grey
  -o            --top                Place xmobar at the top of the screen
  -b            --bottom             Place xmobar at the bottom of the screen
  -a alignsep   --alignsep=alignsep  Separators for left, center and right text
                                     alignment. Default: '}{'
  -s char       --sepchar=char       The character used to separate commands in
                                     the output template. Default '%'
  -t template   --template=template  The output template
  -c commands   --commands=commands  The list of commands to be executed

Mail bug reports and suggestions to <andrea.rossato@unitn.it>

My configuration file

Config { font = "-*-Fixed-Bold-R-Normal-*-13-*-*-*-*-*-*-*"
       , bgColor = "black"
       , fgColor = "grey"
       , position = Top
       , commands = [ Run Weather "EGPF" ["-t","<station>: <tempC>C","-L","18","-H","25","--normal","green","--high","red","--low","lightblue"] 36000
                    , Run Cpu ["-L","3","-H","50","--normal","green","--high","red"] 10
                    , Run Memory ["-t","Mem: <usedratio>%"] 10
                    , Run Swap [] 10
                    , Run Date "%a %b %_d %l:%M" "date" 10
                    , Run StdinReader
                    ]
       , sepChar = "%"
       , alignSep = "}{"
       , template = "%StdinReader% }{ %cpu% | %memory% * %swap%    <fc=#ee9a00>%date%</fc> | %EGPF%"
       }

Configuration copied from haskell wiki. My version of xmobar is 0.9.2.

share|improve this question
add comment

2 Answers

When I try to run xmobar with your config I have the error

xmobar: user error (createFontSet)

It should be different, because I'm using version 0.11.1

To fix that I have to change the line with font setting to

font = "xft:Liberation Mono:pixelsize=10"

Hope that helps :)

share|improve this answer
    
Sorry for delay - it didn't. –  Maciej Piechotka Jan 29 '11 at 18:45
    
@Maciej I don't know much more than that. BTW may I ask why you want to stick with version 0.9.2? –  phunehehe Jan 30 '11 at 3:39
    
Because the account it is installed on have small quota (something like 512MB-1GB) and version 0.9.2 is installed. –  Maciej Piechotka Jan 30 '11 at 12:08
add comment
up vote 0 down vote accepted

This configuration worked:

Config { font = "-misc-fixed-*-*-*-*-13-*-*-*-*-*-*-*"
       , bgColor = "black"
       , fgColor = "grey"
       , position = TopW L 100
       , lowerOnStart = True
       , commands = [ Run Cpu ["-L","15","-H","50","--normal","green","--high","red"] 10
                    , Run Date "%a %b %_d %Y %H:%M:%S" "date" 10
                    , Run StdinReader
                    ]
       , sepChar = "%"
       , alignSep = "}{"
       , template = "%StdinReader% }{ %cpu% | %date%"
       }
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.