Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have recently installed Linux Mint 14 and youtube and other flash based videos are displaying lots of yellow and red specks. It doesn't matter which browser is being used either.

I've tried turning off hardware acceleration which didn't fix it.

Any ideas?

Hardware is an old Lenovo Thinkpad X61 Onboard video is using the driver for Intel 965GM

** Update **

I just thought I'd try the HTML5 video trial on youtube. Instead of using flash it instead uses HTML5 to render the video stream. However, the problem remains only the speckles are now all a red colour.


share|improve this question
To rule out hardware you should try to use a live dvd from another distro – midnightsteel Jan 24 '13 at 13:43
Good idea. I might try that. I have my doubts though as it's actually using a software renderer. – Matt H Jan 24 '13 at 17:09
Haven't had the time yet to test another distro. But what I've noticed is that youtube add's play fine. As soon as the actual video starts it shows the specs. I think this is a software issue. – Matt H Jan 25 '13 at 17:07
Ok, so after some updates I have now found that it works properly in firefox with flash. But not chrome with flash. In chrome, the adverts that appear before the video starts playing properly display properly. As soon as the video starts they appear. If you pause the video the speckles are moving even though the video is paused. – Matt H Jan 26 '13 at 6:01

I've answered a very similar question here: Why is Google Chrome displaying artifacts in YouTube? [closed] but, briefly, it's a technical issue with Google Chrome's Pepper Flash that affects a subset of users. For those who have the problem and want to continue using Google Chrome and Pepper Flash, a workaround involves starting Google Chrome with --disable-accelerated-compositing.

share|improve this answer
up vote 0 down vote accepted

The answer to my own question is. The latest Chrome running on Linux mint is broken.

I have this version installed. Version 24.0.1312.56

I installed the Chromium (the fully OS version) and the problem went away. Chromium is this version:

Version 23.0.1271.97 Built on Ubuntu 12.10, running on LinuxMint 14 (23.0.1271.97-0ubuntu0.12.10.1)

share|improve this answer

Try using another browser. I have no problems if I use Opera for example. Also, I noticed that sometimes after viewing a video in Opera, it starts to work in Chrome too.

I have the same model of computer as you btw. I also suffer from no sound in youtube videos most of the time too. It's a very annoying problem.

I had no such problems when I was using Chromium on Ubuntu, so perhaps Chromium might fix the problem - I'm not sure Chromium uses a built in version of flash, so it's worth a shot.

share|improve this answer
doh! I didn't see you already answered your own question. I'll switch to Chromium too. – Andy Mar 22 '13 at 11:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.