Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've sunk about 6 hours into this and have not made much progress.

I've installed Crunchbang, 32-bit, Waldorf on a Dell Inspiron D600.

Before I took any steps, the network manager told me "firmware missing". Then I ran:

sudo apt-get install firmware-b43legacy-installer

Now, the network manager can see my network but, after I enter the network key, it won't connect. And yes, I'm sure the key is correct.

The instructions I've been following can be found here

If you need further info, please ask in the comments.

share|improve this question
    
We'd need the exact steps you followed (where did you get the firmware from, ...). The page you cite seems to be quite old, many things could have changed. My cursory search says that it should be supported by some reverse engineered driver, please share your research. Look at linuxwireless.org/en/users/Drivers/b43/devices –  vonbrand Jan 24 '13 at 10:05
    
The page I cited was updated last month, and the Dell is 8 years old so I don't think that's the issue. –  Korgan Rivera Jan 24 '13 at 12:39
    
Can you share the content of the kernel logs? –  njsg Jan 27 '13 at 19:55

1 Answer 1

Like the previous post, it would really help to know more information. There's a couple things I know I can point out:

The link is for Arch Linux, which is quite different from Crunchbang (#!). While #! is relatively small in community, many fixes found for Debian and also Ubuntu will work for #!.

Waldorf (11) is still in testing, you might have better luck with Statler (10), which you can download from http://crunchbang.org/download/statler.

You said you are running a live session. I assume there's a reason for not installing it to your hard drive. While in a live session, installing/saving does not carry over to another session. Instead, when rebooting the usb drive (starting a new live session), it will look exactly like when you first started it up.

This looks very helpful and quite straightforward: http://wireless.kernel.org/en/users/Drivers/b43

If you're still having trouble, please give us more information on what you have tried so we can help you better.

share|improve this answer
    
I tried Waldorf because it has a non-PAE option. If Statler has that, which I don't see, then I'll try that. I figured I'd be better off with a stable version though. The reason I haven't installed is this: if I can't get wifi to work, there's no point in installing. –  Korgan Rivera Jan 24 '13 at 22:27
    
"I have a Dell d800 that does not support pae. I am running the latest version of Statler and it is doing great." (crunchbang.org/forums/viewtopic.php?id=18561) This forum has a lot of useful information on your topic. I'd recommend trying Statler and if that doesn't work for some reason, take a look at Debian. –  deafelephant Jan 25 '13 at 5:04
    
Ah, I thought Waldorf was the stable and Statler was the unstable. I will try it. –  Korgan Rivera Jan 27 '13 at 19:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.