Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a brand new install of Ubuntu 10.10 x64 in an attempt to solve the following problem from my previous 10.04 x86 install, but with the exact same problem persisting. When trying to run Amarok or Skype, which I am told produce their GUI component via the KDE and QT frameworks ( I may be misusing these terms but I hope my point comes across ), both of these applications fail to produce menus when a menu producing button is clicked. This of course, makes both of these apps useless.

I installed both apps through the Ubuntu software manager, so expected that any KDE runtime dependencies would have been taken care of already. I then installed kdelibs manually from the console, which didn't appear to be installed already, but this didn't seem to change anything. I installed a QT GUI settings management application to see if somehow menus were turned off or something for QT applications, but the QT settings application itself appears to suffer from the same lack of popdown menus... I don't have this problem with any of my Gnome apps.

What is wrong here? How can I make these applications work?

share|improve this question
    
this could be caused by a broken theme engine, if Qt is using the same GTK theme. Try changing the theme. –  Juliano Jan 21 '11 at 15:17
    
By the way, "QT" = "QuickTime" = Video technology from Apple; "Qt" = "Cute" = GUI cross-platform toolkit from Trolltech/Nokia –  Juliano Jan 21 '11 at 15:17
    
I have had sketchy performance from ubuntu on menus for both GTK and Qt recently. Thinking Juliano is right on the themes. I even had GDM crash during startup when applying theme (in my case I tracked it back to the gnome settings manager app) –  hbdgaf Jan 28 '11 at 11:15
add comment

1 Answer 1

up vote 0 down vote accepted

Solved! It appears that the menus in question relied upon 'visual effects' being enabled in the 'Appearances' section of the user preferences. Turning visual effects to either normal or extra thus fixes this problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.