Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have Fedora 12 and no wish to change. I want to play dvd videos, but these need VLC or mplayer, and they need rpmfusion.

There are many sets of instructions on installing rpmfusion, but they all fail with some mysterious extra requirement, or need Fedora 19, if I read it correctly, or some other arcane error.

The most likely help was at http://www.redips.net/linux/yum-install-mplayer-fedora12/ which said enter:

rpm -Uvh http://download1.rpmfusion.org/free/fedora/pmfusion-free-release-stable.noarch.rpm !!!!! Now even more frustration: That's not what I typed! Although the full command line shows in the edit window for this post, half of it is missing in the preview. Grrrr....

But this command (the full thing of which only half shows above) gives:

bash: syntax error near unexpected token `newline'

But I can't find or remove a 'newline' in the command. I've already spent most of the day on this -- Please can someone help?

Excuse my being fussy, but please no answers suggesting I change to another Fedora release, or not directly addressing the real problem, at least as a first step: how to get rpmfusion in Fedora 12 in a way that actually works.

share|improve this question
    
Did you type out the command or copy-and-paste it? –  Ignacio Vazquez-Abrams Jan 22 '13 at 15:12
    
Ignacio, thanks, I tried both, Harry –  Harry Weston Jan 22 '13 at 16:39
add comment

1 Answer

up vote 2 down vote accepted

Harry,

I would try this first:

rpm -ivh http://download1.rpmfusion.org/free/fedora/releases/12/Everything/i386/os/rpmfusion-free-release-12-1.noarch.rpm

That's the only installer for Fedora 12 I see on the rpmfusion page.

Then try to install VLC if the install of the repo worked. If it didn't, try:

su
rm /etc/yum.repos.d/index.html*
rpm -ivh http://download1.rpmfusion.org/free/fedora/releases/12/Everything/i386/os/rpmfusion-free-release-12-1.noarch.rpm

Then I'd try to install VLC again. If you have dependency issues (which you might based on your version), you may have to install the dependencies directly from rpmfusion.

Hope this helps somewhat.

share|improve this answer
    
Here's where I went to look at repo information for rpmfusion: rpmfusion –  Josh Blair Jan 22 '13 at 16:00
    
Thank you Josh Blair, that worked perfectly. I typed the first command you suggested, and a few minutes later I have VLC running: and I have just paused a DVD video to send this. it could not have worked better, many thanks again. –  Harry Weston Jan 22 '13 at 16:55
    
No problem. Glad I could help! –  Josh Blair Jan 22 '13 at 17:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.