Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Some software that I install on my Ubuntu doesn't appear on the Dash Home menu.

For example, I installed Komodo Edit (thru a .sh file). If I want to run this program, I have to go to the directory where its located and then click on it. If I type Komodo on the dash home menu, it just won't appear.

Could it be it's because I didn't install it thru 'apt-get' (komodo is not available there)

How can I enable a program on the dash home menu?

share|improve this question
    
A part of what packaging by the distribution does is to make sure the correct configuration files are placed, and that the whole mess works well together (for example, making your desktop environment aware of new programs). –  vonbrand Jan 21 '13 at 17:27

1 Answer 1

up vote 5 down vote accepted

Try creating a komodoedit.desktop file and save it on ~/.local/share/applications/ and make it point to your executable file.

[Desktop Entry]
Name=Komodo Edit
Comment=Komodo and stuff
Exec=/path/to/the/execucable/file
Icon=/path/to/an/appropriate/icon
Type=Application
Terminal=false
Categories=Application;Utility;TextEditor;
MimeType=text/plain

Accomodate the values accordingly. You should now be able to at least find it on the menu or search options.

share|improve this answer
    
Worked like a charm. Did just like you told me but only appeared after I restarted the pc, thanks! –  user1091856 Jan 20 '13 at 7:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.