Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I create a RHEL6 server using the DVD media, it works fine. However, we want to do PXE installs.

We import the RHEL6 DVD to cobbler by doing the following:

$ sudo mount -o loop,ro rhel6-dvd.iso /media
$ sudo cobbler import --path=/media/ --name=rhel-6 --arch=x86_64

The install goes through fine. However, it seems that the registration isn't completed correctly. Here is the output:

The system has been registered with id: (snipped ID) 
Installed Product Current Status:

With a regular install, I'd get a list of products. When I do yum repolist, I don't get any of the RHN repos:

# yum repolist
Loaded plugins: product-id, security, subscription-manager
Updating certificate-based repositories.
repo id          repo name                                                status
epel             Extra Packages for Enterprise Linux 6 - x86_64           8,312
repolist: 8,312

Any idea why it is not registering correctly via cobbler but working fine when using DVDs?

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

What worked was copying the DVD media to the local volume (cp -rp /media <cobbler path for media>) and pointing cobbler to that.

I got to this solution after comparing both trees---that of the DVD and that of the results of a cobbler import. Apparently, cobbler import doesn't copy some files for whatever reason. These missing files seem to include the mechanism that RHEL uses to identify the product.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.