Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Related to this question, I have Ubuntu 20.04.1 LTS. I downloaded PlayOnLinux 4.1.9 (the Precise version) and used it to install Microsoft Office 2010 Pro. PlayOnLinux downloaded Wine 1.5.21 and whatever else it needed to install office. I did a customized installation and it seems to work fine. The only issue is now that I can't quite get file associations to work correctly. So for example, if I have a .docx document, I want to be able to just double click it and have it open with Microsoft Word. When I try to do that I get an error saying "IOPL not enabled" and the document never opens. I googled it and everyone said to open up wine configuration, go to libraries, add gdiplus and edit it to "Native (Windows)" but this still hasn't fixed the problem. I have no idea what this is or how it is supposed to work but can someone who does, please help. Currently I have to start Word and then use it to open up the document. That works fine.

I am not very familiar with linux so hope this isn't too complicated and can be broken down into easy steps which I can follow and execute.

Thank you.

share|improve this question
add comment

2 Answers

This is done by creating a small script and then associating it with that file type via 'Open with '. This is available in most desktop environments by rightclicking on one .docx file for example and using the upcoming menu.

Examples and details on how to create such a script can be found in the ubuntu documentation: https://help.ubuntu.com/community/Wine#Creating_file_associations

share|improve this answer
    
That script won't work with software installed using PlayOnLinux, since PoL does not use the default wine prefix (it actually does not even use the default wine executable, it downloads and configures a whole new wine for each app). –  MestreLion Apr 26 '13 at 10:15
    
It is also a useless script for "vanilla" wine, since wine already creates .desktop file associations for all files registered by an installed windows software, so .docx would already be in the "Open with" list of any desktop environments that follow the freedesktop standard file association –  MestreLion Apr 26 '13 at 10:17
    
(not to mention that is a very poorly written script... in only 5 lines it manages to break about a dozen shell scripting good practices and conventions... $*, exit 0, cap (useless) vars, ewww) –  MestreLion Apr 26 '13 at 10:23
add comment

Are your .docx files marked as executable?

(you can check this by right-clicking the file and going Properties > Permissions > Execute checkbox)

Does .doc files open fine when double-clicked?

If you answer 'yes' to both questions, you may be experiencing this, which is related to this nasty bug.

Disabling jar using update-binfmts, as suggested in both links, works great as a permanent fix, but it is also quite technical and a bit intrusive.

A simpler workaround is to uncheck the executable permission in your files. Not, however, that this will not work for files in NTFS or FAT partitions, which is a very common scenario for windows-related files such as docx. If so, you could try re-mounting your NTFS drive using the noexec mount option, which will effectively disable execution permission for all files and thus allow docx files to be opened rather than executed (which does not work anyway, since documents are not binary executables)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.