Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

So there is a notebook that has Scientific Linux 6.3 installed with GNOME 2.

If we don't press any button on the keyboard or move the mouse, the screen of it turns black.

But: if we move the mouse/hit a button when the screen of it went black.. it still stays black.. it's not a hardware problem, it's a problem related to the OS. I didn't find any energy saving options for this in the BIOS.

If the screen is black, we can slightly see that the OS is still running, but it's very-very-very dark..

The only solution is to press the power-on button for 5 seconds to turn the machine off..

Any solutions/settings? Please halp.

UPDATE#1: (I can only rarely get to this notebook, that's why I can only answer rarely, sorry) So I found a settings in gnome-screensaver-preferences: "Activate screensaver when computer is idle" was enabled. I disabled it, and we are waiting for the blank screen to appear again, but this takes time, because I found out that the screen goes to blank randomly (!). Even if there was somebody in front of the notebook and was using the ex.: USB mouse.. strange.. I will update the Q/accept the good answer if this helps:D

UPDATE#2: Until the outcome the xset -q output is this:

[root@HOSTNAME ~]# xset -q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  500    repeat rate:  30
  auto repeating keys:  00ffffffdffffbbf
                    fadfffefffedffff
                    9fffffffffffffff
                    fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
Colors:
  default colormap:  0x20    BlackPixel:  0    WhitePixel:  16777215
Font Path:
  catalogue:/etc/X11/fontpath.d,built-ins
DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On
[root@HOSTNAME ~]#
share|improve this question
    
Could you examine its brightness ACPI settings? Maybe echo 10 > /sys/class/backlight/acpi_video0/brightness does something (then the problem might be cornered) –  sr_ Jan 17 '13 at 15:23
    
that would be just a workaround, but BIG THANKS for it :) –  gasko peter Jan 18 '13 at 10:20
    
Did either of the answers provided help you out? Can you please update your status on your question? thanks. –  slm Jan 25 '13 at 18:53
    
I tried the: "echo 15 > /sys/class/backlight/acpi_video0/brightness" when the screen was blank, but it didn't worked :\ –  gasko peter Jan 26 '13 at 9:26

4 Answers 4

There are some suggestions in this Redhat KB doc.

1. Using GNOME Power Managment Applet

Usually I open up the GNOME Power Management applet and disable any dimming etc. when on AC power. Have you done these things as well?

Right click on the GNOME Power Management icon in your taskbar:

                                                ss gpm applet

Select Preferences from the menu:

                                                   ss of GPM menu

Disable dimming and make everything else Never:

           ss gpm prefs. AC tab

2. gconftool-2, setterm & xset

If the above doesn't work out you can always throw this script at it.

#!/bin/bash

# Disable screensaver start
gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t bool /apps/gnome_settings_daemon/screensaver/start_screensaver false

# Disable screensaver locking
gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t bool /apps/gnome-screensaver/lock_enabled false

# Disable screensaver altogether
gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t bool /apps/gnome-screensaver/idle_activation_enabled false

# Increase screensaver idle time (max 2h, we set to 10h)
gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t bool /apps/gnome-screensaver/idle_delay 600

# Disable DPMS screen blank on AC and battery
gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t string /apps/gnome-power-manager/ac_dpms_sleep_method off 

gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t string /apps/gnome-power-manager/battery_dpms_sleep_method off

# Disable Computer sleep when on AC and battery
gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t integer /apps/gnome-power-manager/ac_sleep_computer 0 

gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t integer /apps/gnome-power-manager/battery_sleep_computer 0

# Disable Display sleep when on AC and battery
gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t integer /apps/gnome-power-manager/ac_sleep_display 0 

gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t integer /apps/gnome-power-manager/battery_sleep_display 0

# Disable Dim-on-Idle
gconftool-2 --direct --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults -s -t bool /apps/gnome-power-manager/dim_on_idle false

# Setterm
setterm -powersave off -blank 0

# xset stuff
xset -dpms
xset dpms 0 0 0
xset s noblank
xset s off

Scripts courtousey this ubuntuforum thread.

share|improve this answer
    
It's in System -> Preferences -> Power Management too. –  Simon Hoare Jan 29 '13 at 16:48

Try running $xset -q or xset -q | grep timeout and xset -q | grep Standby and see if the output is something like this respectively:

timeout:  0    cycle:  600
Standby: 0    Suspend: 0    Off: 0

Gnome should let you set the values for Standby, Suspend and Off to 0 through their power saving settings related to the display. The first part, timeout, is related to the screensaver, but you should be able to set it to 0 with this command:

xset s off

The last part, cycle, hasn't been a problem, at least for me.

share|improve this answer

I found myself in this trouble, until I found this a very simple solution: install caffeine and enjoy.

https://launchpad.net/caffeine

It works in every system that I have ever tested.

share|improve this answer
up vote 0 down vote accepted

the xorg.conf file exists in /etc/X11.. that was the problem.. it was related to the recent problem with rhel/xorg.. that the screen was blank when booted the PC

removed the xorg.conf file, problem solved..

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.