Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having a trouble while installing php5-pdo_mysql in my FreeBSD environment. Everytime I trys to do /usr/ports/databases/php5-pdo_mysql make install the console gives me this error:

/usr/ports/databases/php5-pdo_mysql/work/php-5.3.5/ext/pdo_mysql/mysql_driver.c:
501: error: too many arguments to function 'pdo_mysql_globals.dbg->m->func_leave'

/usr/ports/databases/php5-pdo_mysql/work/php-5.3.5/ext/pdo_mysql/mysql_driver.c:
In function 'pdo_mysql_check_liveness':
/usr/ports/databases/php5-pdo_mysql/work/php-5.3.5/ext/pdo_mysql/mysql_driver.c:
519: error: too many arguments to function 'pdo_mysql_globals.dbg->m->func_leave'

/usr/ports/databases/php5-pdo_mysql/work/php-5.3.5/ext/pdo_mysql/mysql_driver.c:
534: error: too many arguments to function 'pdo_mysql_globals.dbg->m->func_leave'

/usr/ports/databases/php5-pdo_mysql/work/php-5.3.5/ext/pdo_mysql/mysql_driver.c: 
In function 'pdo_mysql_handle_factory':

/usr/ports/databases/php5-pdo_mysql/work/php-5.3.5/ext/pdo_mysql/mysql_driver.c:
763: error: too many arguments to function 'pdo_mysql_globals.dbg->m->func_leave'

*** Error code 1
1 error
*** Error code 1

Stop in /usr/ports/databases/php5-pdo_mysql.
*** Error code 1

Stop in /usr/ports/databases/php5-pdo_mysql.

My php version is 5.3.3 and pear 1.9.1. I tried to upgrade port tree of php5 to 5.3.5 but it failed. Saying I have to update apache22 first, but then updating apache22 also failed. What should I do now?

share|improve this question

put on hold as off-topic by Jeff Schaller, jimmij, cas, MelBurslan, jordanm Jun 21 at 17:07

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, jimmij, cas, MelBurslan, jordanm
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Try this first: cd /usr/ports && make clean, then cd /usr/ports/ports-mgmt/portsnap && make install clean, then portsnap fetch update, then try to upgrade apache. – Yasir Arsanukaev Jan 20 '11 at 4:30
    
Thanks for your response. I was able to update apache22 and php5.3.5. although /usr/ports/ports-mgmt/portsnap && make install clean gave me this error:"portsnap-1.1 is now contained in the base system". but I did portsnap fetch update anyway then updated apache22 and php5 with make deinstall make reinstall. However now I got a different kind of error when I try to install php5-pdo_mysql. – user3927 Jan 20 '11 at 20:23
1  
I just did /usr/ports/databases/php5-pdo_mysql && make deinstall and make reinstall and it worked!! thanks a bunch!! – user3927 Jan 20 '11 at 20:24

Combining the pieces left in comments by Yasir Arsanukaev and user3927

First, try

cd /usr/ports && make clean
cd /usr/ports/ports-mgmt/portsnap && make install clean
portsnap fetch update

Then maybe upgrade Apache and PHP5 with make deinstall reinstall.

Finally, reinstall php5-pdo_mysql with

cd /usr/ports/databases/php5-pdo_mysql && make deinstall reinstall
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.